Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


eggdrop le bot ne fait rien
#1
Bonjour,

alors voilà, après un petit problème j'ai enfin réussi à le faire se lancer.


bon maintenant il est bien sur mon channel j'ai suis le "owner" mais j'ai des commandes et rien de se passe. je fais .help j'ai rien. Dans le fichier de config, j'ai chargé le script 8ball.tcl

j'essaye les commandes de 8ball, rien ne se passe non plus. La seulle chose que j'ai c'est quand je fais /msg lenomdubot help
Et il me dit alors :
Quote:/MSG commands for BOTmamouth:
All users: ADDHOST HELP IDENT INFO PASS VOICE WHO WHOIS
Channel/global halfops: HALFOP INVITE KEY
Channel/global ops: OP GO
Global masters: DIE JUMP MEMORY SAVE REHASH RESET
Channel masters: STATUS
For help on a command, /MSG BOTmamouth HELP <command>. You are a master. Many many more commands are available via dcc chat. There may also be additional commands provided by other modules.
Admin: mamouth


Que faire ? merci :)
#2
Déplacement Ceci semble plus être un souci tcl.

Question primordiale: ton eggdrop est-il sur un canal ? Et as tu bien fait un rehash après avoir mis l'appel au tcl dans la conf ?
Si oui, mets toi en party-line et active le mode debug (.console +b). Ensuite, en canal, tapes ?8ball (ou !8ball).
Si rien ne se passe, copies ici ce qui s'affiche en party-line.
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
#3
L'eggdrop est bien sur un canal si c'est un channel que tu veux dire. Je n'ai pas fait de rehash car j'ai lancer les scripts en même temps que j'ia lancé eggdrop pour la première fois.

Je ne peux même pas me mettre en party-line :
premier essai : /dcc chat BOTmamouth
Chat with BOTmamouth
Waiting for acknowledgement...

second essai : /ctcp BOTmamouth chat
?1BOTmamouth? chat

et puis rien.
#4
Essaye d'accéder à la party-line par telnet, le DCC et le CTCP sont des sources de problèmes.
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
#5
Bizarrement quand il me demande le nickname, je met un pseudo et il me ferme la fenêtre telnet. J'ai essayé avec d'autre pseudo, c'est pareil.

voici le fichier conf si besoin que j'ai bien évidemment chargé à la place de celui par défaut :

Code:
#! ./eggdrop

### Core Settings ###
set admin "mamouth"
set nick "BOTmamouth"
set altnick "BOTmamouth-"
set realname "BOTmamouth"
set network "Others"
set net-type "5"
set init-server { putserv "mode BOTmamouth +i" }
set default-port 6667
set servers {
  euroserv.fr.quakenet.org
  
  
}

set timezone "GMT"
set offset "0"
set env(TZ) "$timezone $offset"
set my-hostname "server5.tonbnc.fr"
set my-ip "178.63.240.150"

### Logfile Settings ###
set max-logs 5
set max-logsize 0
set quick-logs 0
logfile mcobxs * "logs/BOTmamouth.log"
logfile jkp #mamouth "logs/#mamouth.log"
set log-time 1
set keep-all-logs 1
set logfile-suffix ""
set switch-logfiles-at 300
set quiet-save 0

### Console Settings ###
set console "mkcobxs"

### File & Directory Settings ###
set userfile "BOTmamouth.user"
set pidfile "pid.BOTmamouth"
set chanfile "BOTmamouth.chan"
set force-expire 0
set share-greet 0
set use-info 1
set sort-users 0
set help-path "help/"
set text-path "text/"
set temp-path "/tmp"
set motd "text/motd"
set telnet-banner "text/banner"
set userfile-perm 0600
set mod-path "modules/"

### BotNet Settings ###
set botnet-nick "BOTmamouth"
listen 45632 all
set remote-boots 0
set share-unlinks 0
set protect-telnet 1
set dcc-sanitycheck 1
set ident-timeout 0
set require-p 1
set open-telnets 0
set stealth-telnets 0
set use-telnet-banner 0
set connect-timeout 30
set dcc-flood-thr 3
set telnet-flood 5:60
set paranoid-telnet-flood 1
set resolve-timeout 15

### Channel Settings ###
loadmodule channels
set global-flood-chan 4:5
set global-flood-deop 0:0
set global-flood-kick 0:0
set global-flood-join 4:05
set global-flood-ctcp 2:02
set global-flood-nick 5:20
set global-aop-delay 0:00
set global-idle-kick 0
set global-chanmode "nt"
set global-stopnethack-mode 0
set global-revenge-mode 0
set global-ban-time 0
set global-exempt-time 60
set global-invite-time 60

set global-chanset {
    -autoop           +autovoice
    -bitch            -cycle
    +dontkickops      -dynamicbans
    +dynamicexempts   +dynamicinvites
    -enforcebans      -greet
    -inactive         +nodesynch
    +protectfriends   +protectops
    -revenge          -revengebot
    -secret           +seen
    +shared           -statuslog
    +userbans         +userexempts
    +userinvites      -protecthalfops
    -autohalfop
}

channel add #mamouth {
    chanmode "+tn"
    idle-kick 0
    flood-chan 5:4
    flood-join 5:10
    flood-ctcp 3:60
    flood-deop 0:0
    flood-kick 0:0
}
channel set #mamouth -enforcebans -dynamicbans -autoop +autovoice +protectops +protectfriends

### Advanced Settings ###
set ignore-time 5
set hourly-updates 00
set owner "mamouth"
set notify-newusers "mamouth"
set default-flags "hp"
set whois-fields "url birthday"
set die-on-sighup 0
set die-on-sigterm 1
unbind dcc n tcl *dcc:tcl
unbind dcc n set *dcc:set
set must-be-owner 1
unbind dcc n simul *dcc:simul
set max-dcc 50
set enable-simul 1
set allow-dk-cmds 1
set dupwait-timeout 5

### Module Settings ###
loadmodule dns
loadmodule transfer
loadmodule share
loadmodule server
loadmodule ctcp
loadmodule irc
loadmodule notes
loadmodule console
loadmodule blowfish
checkmodule blowfish
loadmodule uptime

set keep-nick 1
set strict-host 0
set quiet-reject 1
set lowercase-ctcp 0
set answer-ctcp 3
set flood-msg 5:5
set flood-ctcp 3:60
set never-give-up 1
set strict-servernames 0
set server-cycle-wait 60
set server-timeout 60
set servlimit 0
set check-stoned 1
set use-console-r 0
set debug-output 0
set serverror-quit 1
set max-queue-msg 300
set trigger-on-ignore 0
set double-mode 0
set double-server 0
set double-help 0
set optimize-kicks 1
set stack-limit 4
set ctcp-mode 0
set bounce-bans 1
set bounce-modes 0
set max-bans 100
set max-modes 30
set kick-fun 0
set ban-fun 0
set learn-users 0
set wait-split 600
set wait-info 180
set mode-buf-length 200
bind msg - ident *msg:ident
bind msg - addhost *msg:addhost
set no-chanrec-info 0
set bounce-exempts 0
set bounce-invites 0
set max-exempts 20
set max-invites 20
set prevent-mixing 1
set max-dloads 3
set dcc-block 1024
set copy-to-tmp 1
set xfer-timeout 30
set share-compressed 1
set max-notes 50
set note-life 60
set allow-fwd 0
set notify-users 1
set notify-onjoin 1
set console-autosave 1
set force-channel 0
set info-party 0

### Script Settings ###
source scripts/8ball.tcl
source scripts/t-2.tcl
source scripts/alltools.tcl
source scripts/action.fix.tcl
#6
Bonsoir mamouth,

Si tu mets le bon pseudo et que le bot ferme la liaison, c' est peu être parce que tu lui mets ton pseudo avec un script activé (bsmax ou autre )
Ce que tu gardes est perdu à jamais. Ce que tu donnes est à toi pour toujours.
#7
Salut frederenaud,

Je n'ai pas très bien compris. J'ai essayé plusieurs pseudo et les seuls scripts activés sont :
source scripts/8ball.tcl
source scripts/t-2.tcl
source scripts/alltools.tcl
source scripts/action.fix.tcl

Je ne vois pas où ca pourrait porter un conflit.
#8
Bonjour mamouth,

Tu dois mettre le pseudo avec lequel tu t 'es reconnu en tant que propriétaire du bot .
Ce que tu gardes est perdu à jamais. Ce que tu donnes est à toi pour toujours.
#9
Pour moi, ça ressemble fort à l'absence d'un utilisateur dans la base users de l'eggdrop.

As tu bien fait:

Code:
/msg BOTmamouth hello
/msg BOTmamouth pass tonpass
Ou lorsque tu te connectes par telnet, est-ce que l'eggdrop ne te dit pas de rentrer NEW comme pseudo ?
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
#10
je pencherais plutôt pour une mauvaise configuration de mirc (ou autre script), t as essayé de te connecter par telnet ?
sinon via putty:
tu rentre l ip du bot, tu coche la case telnet et tu met le port du listen

edit: je suppose aussi que le host enregistré lors de la commande hello n est plus valable donc
Code:
/msg le_bot ident password pseudo
C'est en reconnaissant ses erreurs que l'on progresse ;)
Away
#11
frederenaud :
Oui j'ai bien mis le pseudo avec lequel je me suis reconnu en tant que propriétaire.

CrazyCat :
Oui j'ai déjà fait cela, et non il ne me dit pas de rentrer NEW.

djkenny :
Oui j'ai déjà fait telnet via putty comme tu l'as indiqué, mais quand je rentre un pseudo, sa ferme putty.


nouveau : le bot ne me op pas sur le channel, alors que je suis le propriétaire :(

edit : je n'aurais pas du vouloir le kill et le relancer car maintenant j'ai ça (j'ai vider les fichier BOTmamouth.chan et .user) :

Eggdrop v1.6.20 © 1997 Robey Pointer © 2010 Eggheads
[10:36:10] --- Loading eggdrop v1.6.20 (Fri Mar 11 2011)
[10:36:10] * Please make sure you edit your config file completely.
#12
salut,

j'essayerait de renomer le fichier "eggdrop.user" (genre "eggdrop2.user") et refaire la procedure depuis le debut.

Cordialement.
#13
mamouth Wrote:frederenaud :
Oui j'ai bien mis le pseudo avec lequel je me suis reconnu en tant que propriétaire.

CrazyCat :
Oui j'ai déjà fait cela, et non il ne me dit pas de rentrer NEW.

djkenny :
Oui j'ai déjà fait telnet via putty comme tu l'as indiqué, mais quand je rentre un pseudo, sa ferme putty.


nouveau : le bot ne me op pas sur le channel, alors que je suis le propriétaire :(

edit : je n'aurais pas du vouloir le kill et le relancer car maintenant j'ai ça (j'ai vider les fichier BOTmamouth.chan et .user) :

Eggdrop v1.6.20 © 1997 Robey Pointer © 2010 Eggheads
[10:36:10] --- Loading eggdrop v1.6.20 (Fri Mar 11 2011)
[10:36:10] * Please make sure you edit your config file completely.


alors la pour moi tu n'as pas mis le bon pseudo sinon le telnet ne se fermerai pas (ou alors tu n'as pas le host -telnet!*@* qui est censé se mettre automatiquement)
comme l as dit cestlemien, enlève ton fichier user et recommence de 0 en lançant ton bot avec l option -m

Code:
./eggdrop -m taconf.conf
ensuite
Code:
/msg lebot hello
et
/msg lebot pass ton_pass
fais bien attention de ne pas avoirs d extension lors de l enregistrement
(a vérifier aussi sur eggdrop à la base la longueur maximum du pseudo est de 9 caractères donc si ton pseudo est trop long il sera tronqué automatiquement)

edit:
Quote:[10:36:10] * Please make sure you edit your config file completely.
y te dis que ta configuration n'as pas été correctement éditée
C'est en reconnaissant ses erreurs que l'on progresse ;)
Away
#14
Si si, j'avais regardé dans le fichier BOTmamouth.user et il y avait bien mon nick irc avec le fameux -telnet! dedans


bon j'ai relancé le bot, et il s'est bien lancé cette fois, je n'avais pas supprimer les fichier user :p

il m'a reconnu j'ai bien utilisé un mot de passe.

Cette fois telnet marche. J'ai donc ça :


Code:
Connected to BOTmamout, running eggdrop v1.6.20
     ____                __
    / __/___ _ ___ _ ___/ /____ ___   ___
   / _/ / _ `// _ `// _  // __// _ \ / _ \
  /___/ \_, / \_, / \_,_//_/   \___// .__/
       /___/ /___/                 /_/

Hey mamouth!  My name is BOTmamout and I am running eggdrop v1.6.20, on Linux 2.6.26-2-xen-amd64.

Local time is now 14:29
You are an owner of this bot. Only +n users can see this! For more info,
see .help set motd. Please edit the motd file in your bot's 'text'
directory.
Use .help for basic help.
Use .help <command> for help on a specific command.
Use .help all to get a full command list.
Use .help *somestring* to list any help texts containing "somestring".

Have fun.

Commands start with '.' (like '.quit' or '.help')
Everything else goes out to the party line.

You have no messages.
*** mamouth joined the party line.
Quand je donne des ordres via telnet, le bot exécutes les ordres, mais via irc, rien a faire :(
#15
Il y a du mieux.
Tapes donc .status et ensuite .binds pub et recopie ici le résultat
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away


Possibly Related Threads…
Thread Author Replies Views Last Post
  Commenter des lignes de code TCL fait tout bug.. aliasangelius 2 3,890 05/09/2012, 11:54
Last Post: aliasangelius
  Recherche code tcl ou un dèja fait snip74 11 6,630 06/06/2011, 17:13
Last Post: aliasangelius
  petit soucis la recherche n'affiche jamais rien caline012 7 5,430 15/11/2008, 18:27
Last Post: caline012

Forum Jump:


Users browsing this thread: 1 Guest(s)