Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


eggdrop le bot ne fait rien
#31
je crois savoir d'où venait le problème, j'ai des chmod bidon sur tout mon eggdrop.

EDIT : mais je n'arrive plus à lancer eggdrop avec un script ! à chaque fois il me dit :
Code:
mamouth@server5:~/eggdrop$ ./eggdrop -m egg.conf

Eggdrop v1.6.20 (C) 1997 Robey Pointer (C) 2010 Eggheads
[21:32:05] --- Loading eggdrop v1.6.20 (Fri Mar 11 2011)
[20:32:05] Listening at telnet port 45632 (all).
[20:32:05] Module loaded: channels
[20:32:05] Module loaded: dns
[20:32:05] Module loaded: transfer         (with lang support)
[20:32:05] Module loaded: share
[20:32:05] Module loaded: server
[20:32:05] Module loaded: ctcp
[20:32:05] Module loaded: irc
[20:32:05] Module loaded: notes            (with lang support)
[20:32:05] Module loaded: console          (with lang support)
[20:32:05] Module loaded: blowfish
[20:32:05] Module loaded: uptime
[20:32:05] Tcl error in file 'egg.conf':
[20:32:05] invalid command name "in"
    while executing
"in the partyline)"
    (file "scripts/8ball.tcl" line 18)
    invoked from within
"source scripts/8ball.tcl"
    (file "egg.conf" line 207)
[20:32:05] * CONFIG FILE NOT LOADED (NOT FOUND, OR ERROR)
mamouth@server5:~/eggdrop$
#32
c/c ta version du tcl
C'est en reconnaissant ses erreurs que l'on progresse ;)
Away
#33
Ouai j'ai vu ça, j'ai pris un autre 8ball sur le même site et celui là marche impec :D


OUF :d
#34
Enfin il reste un petit problème :

# to enable in your channel ".chanset <channel> +8ball
# and put an '8ball.txt' in your eggdrop root folder full of
# whatever replies you want, seperated by a new line


J'ai donc mis 8ball.txt (avec les réponses dedans) dans le dossier eggdrop où se trouve donc eggdrop mais il ne charge pas les réponses.

Quote:«21:40:23»{@BOTmamouth} mamouth, my 8-ball says


EDIT : un .rehash et c'est bon :)


Merci vraiment de votre aide !
#35
Bonjour et bien moi mon Eggdrop ne ce connecte pas en PL

[CFS ERROR réponse]: no telnet port
-
[CFS ERROR réponse]: no telnet port
-
[CFS ERROR réponse]: no telnet port
-

J'en ai marre
#36
Il te manque peut-être la ligne:
tcl
listen 3333 all


ou
tcl
listen 3333 users


irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP


Possibly Related Threads…
Thread Author Replies Views Last Post
  Commenter des lignes de code TCL fait tout bug.. aliasangelius 2 3,839 05/09/2012, 11:54
Last Post: aliasangelius
  Recherche code tcl ou un dèja fait snip74 11 6,565 06/06/2011, 17:13
Last Post: aliasangelius
  petit soucis la recherche n'affiche jamais rien caline012 7 5,380 15/11/2008, 18:27
Last Post: caline012

Forum Jump:


Users browsing this thread: 1 Guest(s)