eggdrop 1.6.x et uno
#16
(03/10/2017, 17:08)CrazyCat a écrit : Ca, ce n'est pas démarrer l'eggdrop.
Pour le démarrer, ça se fait depuis le shell en tapant ./eggdrop eggdrop.conf (à condition que le fichier de configuration soit eggdrop.conf).

Dans quel fichier as-tu ajouté source scripts/uno.tcl ?

Tu peux essayer, depuis la party-line, de faire .tcl source scripts/uno.tcl ?

ok desole je le demarre avec ./eggdrop
le source scripts/uno.tcl  je l'ai mis en fin de mon eggdrop.conf
le tcl lui est placer dans le repertoir shell/eggdrop/script.

je vient de le relancer avec ./eggdrop eggdrop.conf et j'ai ceci:

Eggdrop v1.6.21 © 1997 Robey Pointer © 2011 Eggheads
[17:58:54] --- Loading eggdrop v1.6.21 (Tue Oct  3 2017)
[17:58:54] Module loaded: dns
[17:58:54] Module loaded: channels
[17:58:54] Module loaded: server
[17:58:54] Module loaded: ctcp
[17:58:54] Module loaded: irc
[17:58:54] Module loaded: console          (with lang support)
[17:58:54] Module loaded: blowfish
[17:58:54] Listening at telnet port 6671 (all).
[17:58:54] Userfile loaded, unpacking...
[17:58:54] === Master: 5 channels, 1 users.
Je d▒tecte que Master est s'ex▒cute d▒j▒ depuis ce r▒pertoire.
Si ce n'est pas le cas, supprimez 'eggdrop.pid'
(vortex)(~/shell/eggdrop)->
  Répondre   Avertir
#17
Le souci est que tu ne kill pas ton eggdrop avant d'essayer de le relancer.
Fais donc un .die en party-line avant de le redémarrer.
  Répondre   Avertir
#18
(03/10/2017, 18:07)CrazyCat a écrit : Le souci est que tu ne kill pas ton eggdrop avant d'essayer de le relancer.
Fais donc un .die en party-line avant de le redémarrer.

en generale je kill le pid en ssh mais la  j'ai oublier
je vient de le faire et ca donne ca:

Eggdrop v1.6.21 © 1997 Robey Pointer © 2011 Eggheads
[18:12:15] --- Loading eggdrop v1.6.21 (Tue Oct  3 2017)
[18:12:15] Module loaded: dns
[18:12:15] Module loaded: channels
[18:12:15] Module loaded: server
[18:12:15] Module loaded: ctcp
[18:12:15] Module loaded: irc
[18:12:15] Module loaded: console          (with lang support)
[18:12:15] Module loaded: blowfish
[18:12:15] Listening at telnet port 6670 (all).
[18:12:15] Userfile loaded, unpacking...
[18:12:15] === Master: 5 channels, 1 users.
Launched into the background  (pid: 30119)
  Répondre   Avertir
#19
Tu ne dois pas avoir édité le bon .conf, parce que là il n'y a aucun tcl qui semble se charger.
  Répondre   Avertir
#20
(03/10/2017, 23:46)CrazyCat a écrit : Tu ne dois pas avoir édité le bon .conf, parce que là il n'y a aucun tcl qui semble se charger.

c'est le seul eggdrop.conf  que j'ai.
il y a pas un truc a rajouter pour les tcl?
si non quel ligne je devrais verifier par rapport au lancement des tcl?
  Répondre   Avertir
#21
Non, il n'y a rien de particulier à ajouter pour que les tcl soient pris en compte.
Peux tu copier ton .conf sur https://tools.eggdrop.fr/pasteme/ ?
  Répondre   Avertir
#22
(04/10/2017, 09:36)CrazyCat a écrit : Non, il n'y a rien de particulier à ajouter pour que les tcl soient pris en compte.
Peux tu copier ton .conf sur https://tools.eggdrop.fr/pasteme/ ?

voila c'est fait

https://tools.eggdrop.fr/pasteme/view/4c409597
  Répondre   Avertir
#23
Ah ben oui, si tu mets un # devant l'appel, ça en fait un commentaire.
  Répondre   Avertir
#24
(04/10/2017, 12:54)CrazyCat a écrit : Ah ben oui, si tu mets un # devant l'appel, ça en fait un commentaire.

ah oui effectivement et ca ma pas fait tilt Sad(
je vient de le modifier et maintenant j'ai une erreure

Eggdrop v1.6.21 © 1997 Robey Pointer © 2011 Eggheads
[16:46:59] --- Loading eggdrop v1.6.21 (Wed Oct  4 2017)
[16:46:59] Module loaded: dns
[16:46:59] Module loaded: channels
[16:46:59] Module loaded: server
[16:46:59] Module loaded: ctcp
[16:46:59] Module loaded: irc
[16:46:59] Module loaded: console          (with lang support)
[16:46:59] Module loaded: blowfish
[16:46:59] Listening at telnet port 6670 (all).
[16:46:59] Tcl error in file 'eggdrop.conf':
[16:46:59] invalid command name ""
    while executing
""
    (file "scripts/uno.tcl" line 1)
    invoked from within
"source scripts/uno.tcl"
    (file "eggdrop.conf" line 102)
[16:46:59] * FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)
(vortex)(~/shell/eggdrop)->
  Répondre   Avertir
#25
Soit tu as fait une erreur dans la casse du nom de fichier soit tu ne l'as pas autorisé en lecture.
  Répondre   Avertir
#26
(04/10/2017, 17:14)CrazyCat a écrit : Soit tu as fait une erreur dans la casse du nom de fichier soit tu ne l'as pas autorisé en lecture.

merci pour ta patience,
lequel doit etre autorisé en lecture?
eggdrop.conf ou uno.tcl
  Répondre   Avertir
#27
uno.tcl, eggdrop.conf l'est sinon l'eggdrop ne pourrait pas démarrer
  Répondre   Avertir
#28
A voir l'erreur, je dirais plutôt que le fichier uno.tcl a été modifié et qu'il y a quelque chose que Tcl ne comprend pas à la ligne 1 du fichier.
  Répondre   Avertir
#29
(04/10/2017, 18:28)MenzAgitat a écrit : A voir l'erreur, je dirais plutôt que le fichier uno.tcl a été modifié et qu'il y a quelque chose que Tcl ne comprend pas à la ligne 1 du fichier.

Ah oui, j'ai lu trop vite Smile
  Répondre   Avertir
#30
(05/10/2017, 00:01)CrazyCat a écrit :
(04/10/2017, 18:28)MenzAgitat a écrit : A voir l'erreur, je dirais plutôt que le fichier uno.tcl a été modifié et qu'il y a quelque chose que Tcl ne comprend pas à la ligne 1 du fichier.

Ah oui, j'ai lu trop vite Smile

je vois vraiment pas quoi, j'ai meme essayer d'enlever l’entête car j'avais ceci:

[07:34:49] invalid command name "#"
    while executing
"# Marky's Uno v0.96"
    (file "scripts/uno.tcl" line 1)
    invoked from within


mais ça a rien changer, je joint le tcl pour que vous voyez le début

je vais essayer avec un autre tcl simple pour voir si il le lance..

je vient s'essayer le Motus et lui pas de soucis:

[15:52:50] (vortex[AFK]) .rehash
[15:52:50] <Master> [15:52:52] #vortex# rehash
[15:52:50] <Master> Rehashing.
[15:52:50] <Master> [15:52:52] Rehashing ...
[15:52:51] <Master> [15:52:52] Listening at telnet port 6670 (all).
[15:52:51] <Master> [15:52:52] [Motus - info] Création d'un enregistrement pour le chan #Motus.
[15:52:51] <Master> [15:52:52] Motus v3.355.20170719 (©2005-2017 Menz Agitat) a été chargé
[15:52:51] <Master> [15:52:52] Userfile loaded, unpacking...

donc je suppose que c'est dans le uno.tcl qu'il y a un soucis
  Répondre   Avertir


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)