[splitted] eggdrop 1.9.1 DCC Chat trouble
#1
Ok noted..

when i tried using latest version 1.9.1 .. i'm having issues with dcc chat from the bot .. that's why i don't use the latest version.. only i use 1.6.21 :))
  Reply
#2
Hi,
Wich problème with dcc chat from the bot?
  Reply
#3
tcl
Acknowledging chat request...
DCC Chat connection established
-
DCC session closed
-




i think this is mostly issues with other users..
  Reply
#4
In your config file change this :
tcl
set vhost4 "n.cafechat.org"
set listen-addr "192.157.193.103"
listen 1357 users
set protect-telnet 0
set nat-ip "127.0.0.1"


with your information

source : http://forum.egghelp.org/viewtopic.php?t=20825
  Reply
#5
don't have issues with 1.6.21 in dcc chat..

only in

(1.9) 1.8.4 with ipv6 

and 

(1.9) 1.8.4 with ipv4

i'll try and check it..
  Reply
#6
I'd splitted the thread because it's another trouble than eggdrop 1.6.21 and ipv6.

Can you share your eggdrop configuration using https://tools.eggdrop.fr/privatebin/ ?
And how did you try to chat with your eggdrop ? using /dcc chat eggdrop ? Can you try with /ctcp eggdrop chat ?

The trouble can simply being with your shell and IPv6 (firewall rules ?)
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
  Reply
#7
thank you CrazyCat, and sorry for mixing the topic ..  :)))


i'm using default .conf from eggdrop 

https://tools.eggdrop.fr/privatebin/?126...a1DXQqCKUX


even in telnet can't connect.
  Reply
#8
Well, I already see two troubles:
Code:
## If you have a NAT firewall, enter your outside IP here. This IP
## is used for transfers and CTCP replies only, and is different than the
## vhost4/6 and listen-addr settings. You likely still need to set them.
set nat-ip "127.0.0.1"
1. you set a NAT firewall on the same host, so there is no NAT
2. ip is IPv4 when you want to use IPv6
Try comment out this line

And have you really several IP on your shell ? If no, don't set vhost6, let the eggdrop manage its own IP.
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
  Reply
#9
im using ipv6;

tcl
set vhost6 "2607:f130:0:ee::b1f0:cb04"



before is like this

Code:
## If you have a NAT firewall, enter your outside IP here. This IP
## is used for transfers and CTCP replies only, and is different than the
## vhost4/6 and listen-addr settings. You likely still need to set them.
#set nat-ip "127.0.0.1"


but still can't dcc chat even i've uncomment it. still can't dcc
  Reply
#10
Try restart your eggdrop (kill it) and retry to telnet it.
I made a test:
Code:
telnet 2607:f130:0:ee::b1f0:cb04 34341
Trying 2607:f130:0:ee::b1f0:cb04...
Connected to 2607:f130:0:ee::b1f0:cb04.
Escape character is '^]'.
Connection closed by foreign host.
So, it looks like the eggdrop refuse me. Your .conf is really lite, maybe a default setting is blocking your connection
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
  Reply
#11
i tried still no luck .. anyway i will try to reinstall again..

is there any tcl script you know to cater dcc chat with the bot?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)