Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


[script] Eggdrop RSS Syndication
Voici comment il est configuré :

Quote: set rss(PTN) {
"url" "http://www.play-the.net/rss/all.rss"
"channels" "#STRss"
"database" "./databases/PTN.db"
"output" "\\\[\002PTN\002\\\] @@item!title@@ - \[string map { \"&from=rss\" \"\" } \"@@item!Link@@\"\]"
"trigger" "!@@feedid@@"
"update-interval" 1
"announce-output" 10
"trigger-output" 5
"evaluate-tcl" 1
}

Avec le https, quand je tape !PTN sur le canal, j'ai le droit a une erreur dans la party line :
- RSS Error : unable to find tls package required for https, unloaded feed 'PTN'

Je pense qu'il manque un package pour le https, et que finalement, la lib8.5 serait très utile.

Et quand je transforme, le https, en http , j'ai le droit à :
- RSS Warning: couldn't open ".satabases/PTN.db": no such file or directory.



EDiT : J'ai trouvé une version lib 8.5 mais le soucis persiste :/
Oui, il te manque bel et bien un package (qui appartient à OpenSSL je crois). Malheureusement, sous windows, je ne pourrais pas t'aider.

Et c'est normal que ça ne fonctionne pas en http, car le serveur te rebascule automatiquement en https. Voila ce que c'est que de vouloir annoncer des infos pirates.
Attention à Hadopi et TMG.
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
J'ai cherché dans les utilitaires, il n'y a aucun script ou package pourtant ce nom :/
Pour ce qui es de Hadopi, je ne fait rien de mal d'afficher ces infos sur un canal
Ce n'est pas moi qui partage les fichiers pirates en question ^^
Bonjour à tous !
J'ai récemment galéré pendant une journée à configurer un Eggdrop (c'est la première fois ^^), et j'ai utilisé ce script pour le RSS ^^
Par contre j'ai un problème, non pas que le bot ne fonctionne pas, mais je voudrais qu'il fasse autre chose.

Voilà la conf :

Quote: set rss(BashFR) {
"url" "http://feeds.feedburner.com/bashfr-quotes"
"channels" "#anfansub"
"database" "./databases/bashfr.db"
"output" "\\\[\002BashFR\002\\\] @@item!title@@ (@@item!slash:section@@) - \[string map { \"&from=rss\" \"\" } \"@@item!feedburner:origLink@@\"\]"
"trigger" "!bashfr"
"evaluate-tcl" 1
}

-----------------------------------------------------------------------------

EDIT : Le problème est réglé, il y a justement un script tcl exprès pour bashfr, je n'avais pas assez cherché (honte à moi !).
Salut a tous,

J'ai un petit soucis, une erreur de mon script rss

Il marche nickel, tous s'affiche bien sur le chan irc, seulement, dans la party-line, j'ai une cette erreur qui reviens toutes les minutes piles :

[23:22:00] Tcl error [::rss-synd::getFeeds]: can't read "feed(update)": no such element in array

celle la aussi

[23:32:00] Tcl error [::rss-synd::feed_get]: invalid command name "::rss-synd::feed_get"

merci pour votre aide
Quelle version de rss-synd utilises tu ?
Je ne vois pas de procédure getFeeds dans la version v0.5b1.
Et il n'y a pas de variable feed(update) mais il y a feed(updated)... N'aurais-tu pas édité le fichier et provoqué quelques erreurs par mégarde ?
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
CrazyCat Wrote:Quelle version de rss-synd utilises tu ?
Je ne vois pas de procédure getFeeds dans la version v0.5b1.
Et il n'y a pas de variable feed(update) mais il y a feed(updated)... N'aurais-tu pas édité le fichier et provoqué quelques erreurs par mégarde ?

bonsoir CrazyCat

effectivement, je sais pas ce que j'ai fait mais j'avais la version du script de 2005 , donc j'ai pris la v0.5b1 de 2007 et là, plus une seule erreur.

Le premier de 2005 devait mal être mal fait.

Par contre j'ai une notification dans la party-line, au bout de 5minutes environ, une fois le egg connecté au serveur, je cite :

[19:57:00] <Egg> [19:57:00] Je n'ignore plus *!*@xevion.net (a expiré)

J'ai demandé à un admin ce que sa voulait dire, il m'a dit :

[21:05:11] <Admin> Faut ajoute une exception au système de flood de l'eggdrop pour *!*@xeviont.net
[21:05:19] <Admin> En gros, quand l'egg se co
[21:05:24] <Admin> Il recoit pas mal de messages des services
[21:05:38] <Admin> (salut, je te connais et t'es pas co envoi moi ton pass, ect...)
[21:05:49] <Admin> Ca plait pas à l'eggdrop et il ban le mask


Mais ne voulant pas le déranger trop longtemps, je m'en remet à vous, après avoir cherché sur le net sans rien trouvé.

Donc si vous pourriez m'aider ou me diriger vers une fiche pour un ajout d’exception de Flood de l'eegdrop, sa serait sympa. Merci
Salut,

Après avoir rechercher ?
Pas sur le forum je pense.

Tien regarde un exemple : http://www.eggdrop.fr/board/Ne-pas-ignor...-t-88.html
Ta toutes la solution ici =)
Salut,

J'ai recherché dans google en tapant : eggdrop ajout exception flood
Mais je savais pas trop comment recherché exactement, c'est vrai qu'en tapant : ne pas ignorer nickserv , sa aurait été trouvé

Faut juste savoir ce que l'on recherche avec les bons mots clés...

Merci à toi, c'est résolu :)
Salut à tous, j'ai récemment créé un channel exprès pour du RSS, et j'en ai ajouté 90. Sur les 90, y'en a que 26 qui fonctionnent, pour tous les autres je reçois cette erreur :


Code:
RSS Warning: couldn't open "./scripts/feeds/xxxxx.db": no such file or directory.
(voir ce lien : http://puu.sh/1fsb8)

Habituellement le bot crée les databases automatiquement, mais pour je ne sais quelle raison, cette fois-ci il ne le fait pas (peut-être lui ai-je donné trop de travail d'un seul coup ?).

PS : J'ai actuellement la version 0.5b1 du script.

Merci d'avance pour votre réponse.
Actualise ton shell..

Normalement sa devrais être fait le fichier db.
Il mets cette erreur car y a rien qui en créer des database lorsque nous rajoutons des liens flux rss.

Donc tu à l'erreur en Party-Line mais si tu actualise ou se situe t'es blabla.db tu devrais voir que tu as bien le fichier de fait.
Et bien non justement, ils n'y sont pas...
J'ai bien précisé que d'habitude le bot les crée, et que cette fois non.

Les fichiers ne sont pas présents, et l'erreur revient à chaque fois que je tape les triggers.
Ta essayer un rehash ?
Tu as bien indiquer des noms différents ?

Sinon en flux rss si celà ne foncionne toujours pas essaye celui ci : http://scripts.eggdrop.fr/details-Rss-Sy...-s135.html
Oui j'ai mis des noms différents pour chaque RSS (comme on peut le voir sur mon screen), et des .rehash j'en fais tout le temps.

Merci, je vais tester avec celui-ci ^^
bonjour,
mais ton dossier databases existe t il bien car dans ton premier message tu nous indique un messages d'erreur >>
RSS Warning: couldn't open ".satabases/PTN.db": no such file or directory.
ou il devrait se nomer satabases
n'aurais tu pas une erreur de frappe qq part
de plus, tant le fichier est créé lors d'une première utilisation, mais le dossier ne l'est jamais


Forum Jump:


Users browsing this thread: 1 Guest(s)