utf8
#1
Salut a tous. Je roule le eggdrop 1.6.21 que j'ai d'abord compilé avec ceci :

en remplaçant dans main.h
Code :
#if (((TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION >= 1)) || (TCL_MAJOR_VERSION > 8))
#  define USE_TCL_BYTE_ARRAYS
#  define USE_TCL_ENCODING
#endif

par

Code :
#if (((TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION >= 1)) || (TCL_MAJOR_VERSION > 8))
#  undef USE_TCL_BYTE_ARRAYS
#  define USE_TCL_ENCODING
#endif

et en modifiant dans tcl.c

Code :
if (encoding == NULL) {
  encoding = "iso8859-1";
}

par ceci

Code :
if (encoding == NULL) {
  encoding = "iso8859-1";
  encoding = "utf-8";
}

sans succès alors j'ai essayé

Code :
if (encoding == NULL) {
  encoding = "iso8859-1";
}
encoding = "utf-8";

sans succès alors j'ai essayé

Code :
if (encoding == NULL) {
  encoding = "utf-8";
}

sans succès non plus. j'ai donc utilisé le script tcl du site http://eggwiki.org/Bugs/Utf-8
Je l'ai chargé après les modules et avant tout les scripts mais ne marche pas!

Avez-vous une idée?

Merci
  Répondre   Avertir
#2
Quel est exactement le souci que tu as ? Et sur le wiki, il y a http://wiki.eggdrop.fr/Utf-8#Canaux_UTF-8 si le souci est pour rejoindre les canaux en UTF-8.
  Répondre   Avertir
#3
J'utilise le public quote system et les accents aigu, grave, etc sont remplacés par des caractères illisible. Même chose pour le stats avec pisg donc je suppose que mes différentes manœuvre pour utf-8 n'ont pas fonctionnés.
  Répondre   Avertir


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  [UTF8] mettre le caractere " € " dans un tcl pour que l'eggdrop puisse l'ecrire mecmec 2 2,787 26/07/2011, 18:55
Dernier message: mecmec

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)