Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


Probleme avec commande AJOUT d'users
#7
CrazyCat J'ai bien ajouté comme tu as dit

mais il y a un conflit avec une commande pour se op.

voici le premier code

tcl
bind pub n .+@ Ajoutop
proc Ajoutop {nick uhost hand chan arg} {
	global botnick  
      set nick [lindex $arg 0]
	  if {[validuser $nick]} {
		puthelp "NOTICE $hand :$nick est déja Ajouté Comme Propriétaire"
		return 0
	}
	  putquick "MODE $chan +o $nick"
      adduser $nick $nick!*@*
      chattr $nick +na
	  putserv "PRIVMSG $::chanback : $nick fait maintenant partie de la Team $::Nomback ! Bienvenue. :) "
}


Donc maintenant quand j'ajoute USER en proprietaire et que USERS arrive sur le salon ca ne op pas la mauvaise personne.

Mais par contre maintenant quand la bonne personne donc USER prend une extension exemple : USER|mange
et bien le code suivant ne fonctionne plus

voici le code

tcl
bind pub o !op op
proc op {nick host hand chan arg} {
set nicks [join [lindex [split $arg] 0]]
if {$nicks == ""} {
putserv "privmsg $::chanback :$nick vient de se OPER sur $chan"
putquick "mode $chan +o $hand"
} else {
putserv "privmsg $::chanback :$nick vient de OPER $nicks sur $chan"
putquick "mode $chan +o $nicks"
}
}


Apparement le bot ne reconnait plus le flag donné quand la personne prend une extension, car meme l'auto-op de l'eggdrop flag +a ne reop pas l'user.
Comment je peux faire pour que la commande !op detecte aussi bien USER que USER|mange ??

PS: l'extension mange est un exemple.

Merci d'avance


Messages In This Thread
RE: Probleme avec commande AJOUT d'users - by loulou7593 - 03/06/2010, 13:54

Possibly Related Threads…
Thread Author Replies Views Last Post
  probleme avec le script Pooshy.tcl LTEF 18 454 22/06/2022, 12:49
Last Post: CrazyCat
  Problème avec Les poupées linkeuses zappeur78 22 5,575 31/03/2022, 16:52
Last Post: CrazyCat
  [Demande] Interdire Users sur un canal Staff only uDc 3 214 12/12/2021, 20:59
Last Post: uDc
  [Résolu] Problème avec le script autolog T3nS 2 3,275 06/12/2017, 16:08
Last Post: T3nS
  [Bug] Problème avec le script zurl.tcl T3nS 0 3,101 03/08/2017, 19:40
Last Post: T3nS
  [Résolu] Commande /plainte pseudo raison gérer par un eggdrop avec un alias Unrealircd Alucard`68 3 4,021 01/02/2017, 03:39
Last Post: Alucard`68
  [Résolu] Problème d'accents avec script TCL maison CC30 3 4,756 25/08/2016, 13:55
Last Post: Alucard`68
  probleme de commande sur KAOS loulou7593 43 26,191 30/03/2016, 23:44
Last Post: ShowDowN
  [Résolu] Soucis avec une commande Scorpio 11 6,446 22/01/2016, 12:58
Last Post: Scorpio
  [Résolu] Problème d'encodage avec rss-synd Naruto 24 13,686 18/05/2014, 21:16
Last Post: CrazyCat

Forum Jump:


Users browsing this thread: 1 Guest(s)