Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


[Aide] Installation TWAPI
#1
Bonjour,

A ce jour j'essaye d'installer la librairie TWAPI (twapi-3.0.29-bin.zip) pour mon eggdrop (Eggdrop v1.6.20 Handlen32) sur un Windows Server 2007 Datacenter SP2 32Bit, je rencontre des difficultés.
Voici mon script :

Code:
bind pub -|- !serv service:status
lappend ::auto_path d:/windrop/lib
package require twapi
proc service:status { nick uhost hand chan arg } {
    putquick "PRIVMSG #Secured : auto_path : $::auto_path"
        ###auto_path : ./lib/tcl8.5 ./lib /usr/local/lib d:/windrop/lib
    set sstate [::twapi::get_service_state Mysql]
    putquick "PRIVMSG #Secured : Mysql iS : \00313$sstate"
}
La package n'est pas trouvé :

Code:
[20:15] Tcl error in file 'eggdrop.conf':
[20:15] can't find package twapi
    while executing
"package require twapi"
    (file "scripts/serv.tcl" line 3)
    invoked from within
"source scripts/serv.tcl"
    (file "eggdrop.conf" line 238)
[20:15] * FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)
Localisation des fichiers :

Code:
D:\windrop\lib\twapi\pkgIndex.tcl
D:\windrop\lib\twapi\twapi.dll
D:\windrop\lib\twapi\twapi64.dll
J'ai également essayé de chargé directement fichier DLL comme ceci :

Code:
load twapi-x86-3.0.29.dll
ou
load twapi.dll #(Avec la DLL comprise dans le twapi-3.0.29-bin.zip)
fichiers DLL dans :
D:\windrop\twapi-x86-3.0.29.dll
D:\windrop\twapi.dll

Avec cette configuration la commande n'est pas reconnu, pourtant aucune erreur de chargement de DLL

Code:
Tcl error [service:status]: invalid command name "::twapi::get_service_state"
J'ai également essayé de chargé la librairie depuis twapi-3.0.29.zip

1)eggdrop.conf :

Code:
source scripts/twapi/pkgIndex.tcl
ou
source scripts/twapi/twapi.tcl
ou
source scripts/twapi/services.tcl
[/code]
mais tjs la même erreur
erreur : Tcl error [service:status]: invalid command name "::twapi::get_service_state"

ET j'ai également cette erreur qui revien tout le temps:

Code:
cygwin warning:
  MS-DOS style path detected: d:/Pr3b0t/lib/tclIndex
  Preferred POSIX equivalent is: /Pr3b0t/lib/tclIndex
  CYGWIN environment variable option "nodosfilewarning" turns off this warning.
  Consult the user's guide for more details about POSIX paths:
    http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
Quelqu'un aurait une solutions svp ?


Messages In This Thread
[Aide] Installation TWAPI - by eMayl0 - 07/02/2011, 22:19
RE: [Aide] Installation TWAPI - by djkenny - 08/02/2011, 19:25

Forum Jump:


Users browsing this thread: 1 Guest(s)