Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


[Résolu] script love system
#1
bonjour

je vien vous voir parce que j'ai un probleme avec le script Love System by Marc & Artix v2.1

quand je tape !couple paul alain sa me dit en pl

Tcl error [pub_couple]: invalid bareword "0x"
in expression "0xâ";
should be "$0x" or "{0x}" or "0x(...)" or ...


ya t'il quelqu'un qui pourrais m'aider a corriger le probleme

merci d'avance :)
#2
Déjà, je viens de le télécharger, et c'est un .rtf et non pas un .tcl... C'est moche. Je viens de mettre le script "propre" à la place.

Pour ton souci, il semble plutôt être dans la procédure percenthash :
tcl
proc percenthash string {
   set output 0
   foreach {c1 c2} [split [md5 $string] {}] {
     incr output [expr 0x$c1$c2]
   }
   return [expr $output %101]
}


Est-ce qu'il n'y a pas eu de modifs depuis tcl8.5 sur le "expr 0x" qui est censé convertir d'hexa en décimal ?

Dans le doute, commence par télécharger la version que j'ai remise en ligne, et teste.
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#3
merci CrazyCat de m'avoir répondu

j'ai tester la version que tu a mis en ligne.

mais j'ai toujours la même erreur en pl.

invalid bareword "0x"
in expression "0xÂ";
should be "$0x" or "{0x}" or "0x(...)" or ...
#4
j'ai essayer aussi celui là

TCL :
proc percenthash string {
set output 0
foreach {c1 c2} [split [md5 $string] {}] {
incr output [expr 0x$c1$c2]
}
return [expr $output %101]
}

mais j'ai toujours une erreur en pl


Tcl error [pub_couple]: invalid bareword "0x"
in expression "0xÂ";
"$0x" or "{0x}" or "0x(...)" or ...
#5
C'est très étrange, je regarde ça d'ici demain soir. Mais tu n'es pas le seul à avoir ce genre de souci: http://stackoverflow.com/questions/20120...expression
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#6
d'accord CrazyCat j'entend de tes nouvelles.

et j'ai regarder le lien que tu a mis et éffectivement ya pas juste moi.

moi de mon coté je fait des recherches pour essayer de règle le probleme.
#7
Bon, étrange:
Code:
.tcl proc percenthash string { set output 0; foreach {c1 c2} [split [md5 $string] {}] { incr output [expr 0x$c1$c2] }; return [expr $output %101] }
[12:04:53] tcl: builtin dcc call: *dcc:tcl CrazyCat 24 proc percenthash string { set output 0; foreach {c1 c2} [split [md5 $string] {}] { incr output [expr 0x$c1$c2] }; return [expr $output %101] }
[12:04:53] tcl: evaluate (.tcl): proc percenthash string { set output 0; foreach {c1 c2} [split [md5 $string] {}] { incr output [expr 0x$c1$c2] }; return [expr $output %101] }
Tcl:
.tcl percenthash paulalain
[12:06:14] tcl: builtin dcc call: *dcc:tcl CrazyCat 24 percenthash paulalain
[12:06:14] tcl: evaluate (.tcl): percenthash paulalain
Tcl: 61
Après un restart:
Code:
.tcl source scripts/love.tcl
[12:10:09] tcl: builtin dcc call: *dcc:tcl CrazyCat 24 source scripts/love.tcl
[12:10:09] tcl: evaluate (.tcl): source scripts/love.tcl
Code:
12:10:42 @CrazyCat | !love paul alain
12:10:45    @Artus | Les Probalités d'affinité entre paul et alain sont de : 61  %

Donc pour moi tout semble bien passer...
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#8
ok bizzard parce que moi rien ne marche, j'ai toujours la même erreur en pl

je me demandai si sa pourrai pas être acause de la version de l'eggdrop ??

ma version de mon eggdrop est eggdrop1.8.0
#9
C'est possible, j'ai testé sur un eggdrop 1.6.21.
Mais ça peut aussi être ta version de tcl, laquelle utilises-tu ?
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#10
si je comprend bien a ce que tu me demande a propos de la version de tcl.

j'utilise le tcl8.5
#11
Ok, idem pour moi. Je testerai sur un eggdrop 1.8.x
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#12
ok CrazyCat j'attend de tes nouvelles
#13
Bon, désolé, test réalisé avec un eggdrop 1.8 et ça marche tout aussi bien:
Code:
I am devian, running eggdrop v1.8.0+fixbotnetloop: 3 users (mem: 112k).
En ligne depuis 00:03 (arri�re plan) - CPU: 00:00.08 - Cache hit: 15.8%
Configured with:  '--prefix=/home/eggdrop/eggdrop_1.8'
Config file: devian.conf
OS: Linux 3.14.32-xxxx-std-ipv6-64
Process ID: 22292 (parent 1)
librairie Tcl: /usr/share/tcltk/tcl8.5
Tcl version: 8.5.17 (header version 8.5.11)
Tcl is threaded.
TLS support is enabled.
TLS library: OpenSSL 1.0.1k 8 Jan 2015
IPv6 support is enabled.

Code:
11:16:05 CrazyCat | !love paul alain
11:16:08   devian | Les Probalités d'affinité entre paul et alain sont de : 61  %
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
#14
bon après avoir chercher, j'ai fini par trouve mon souci.

c'était un de mes scripts.

le script que j'avait un souci avec http-title.

et un gros merci a toi CrazyCat d'avoir passer du temps, pour m'aider a régler mon souci :)


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Résolu] HELP System de link pour les jeux BaGrift 6 5,489 07/08/2014, 15:03
Last Post: BaGrift

Forum Jump:


Users browsing this thread: 1 Guest(s)