Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


rss-synd.tcl
#1
Yop :)

J'ai un petit souci avec le tcl rss-synd.

Le script fonctionne lorsque l'eggdrop se connecte au chan. Les flux sont bien affichés.

Par contre lorsque je tape la commande !rss_news (pour ma part), il ne m'affiche rien, et je n'ai aucune erreur ni sur le chan, ni en PL.

Voici mon code "rss-synd-settings.tcl"


Code:
#
# Start of Settings
#

#
# See the README file for more information
#

namespace eval ::rss-synd {
    variable rss
    variable default

    set rss(flux_news) {
        "url"            "http://www.bavardages.org/rss/flux_news.xml"
        "channels"        "#bavardages"
        "database"        "./scripts/feeds/flux_news.db"
        "output"        "\00301.: RSS News ::\00302 @@item!title@@ \00301::\00302 \037@@item!link@@\037 \00301:."
        "trigger"        "!rss_news"
        "evaluate-tcl"    1
    }
    
    set rss(flux_posts) {
        "url"            "http://www.bavardages.org/rss/flux_posts.xml"
        "channels"        "#bavardages"
        "database"        "./scripts/feeds/flux_posts.db"
        "output"        "\00301.: RSS Posts ::\00302 @@item!title@@ \00301::\00302 \037@@item!link@@\037 \00301:."
        "trigger"        "!rss_posts"
        "evaluate-tcl"    1
    }

    # The default settings, If any setting isn't set for an individual feed
    #   it'll use the defaults listed here.
    #
    # WARNING: You can change the options here, but DO NOT REMOVE THEM, doing
    #   so will create errors.
    set default {
        "announce-output"    3
        "trigger-output"    3
        "remove-empty"        1
        "trigger-type"        0:2
        "announce-type"        0
        "max-depth"            5
        "evaluate-tcl"        0
        "update-interval"    30
        "output-order"        0
        "timeout"            60000
        "channels"            "#channel1"
        "trigger"            "!rss @@feedid@@"
        "output"            "\[\002@@channel!title@@@@title@@\002\] @@item!title@@@@entry!title@@ - @@item!link@@@@entry!link!=href@@"
        "user-agent"        "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2"
    }
}

#
# End of Settings
#
################################################################################
Si quelqu'un trouve la solution à mon problème, je suis preneur ;)
#2
Yep poto :)

J'ai regardez donc ton soucis.

J'ai mis le rss-sindic version v0.5b1 et ça fonctionne.

Je te montre comment j'ai ça je vais post le tcl complet ici man :)

Test voir :)
#3
Yop :)

Ouai ca marche ;)

Mais c'est le tinyurl qui ne marche pas maintenant :p
#4
Oui version en cours.. mais comme je l'ai dit sur Epiknet lors d'une conversations ensemble.

Tu fera le testeur comme beaucoup de personne pour voir si ce bug existe chez d'autres ou pas :)


Possibly Related Threads…
Thread Author Replies Views Last Post
Star sslv3 alert handshake failure sur un flux rss avec rss-synd.tcl MenzAgitat 4 2,787 08/08/2019, 22:21
Last Post: MenzAgitat
  [Résolu] Problème d'encodage avec rss-synd Naruto 24 13,631 18/05/2014, 21:16
Last Post: CrazyCat
  [Bug] bug lien court rss-synd.tcl pingyan 1 3,543 04/11/2013, 10:16
Last Post: CrazyCat
  problème avec rss-synd prates 0 3,624 08/08/2010, 08:21
Last Post: prates

Forum Jump:


Users browsing this thread: 1 Guest(s)