Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


probleme avec les uno.tcl
#1
Bonjour

Alors voila quand je veux lancer mon egg, j'ai cette erreur qui s'affiche :


error reading "file9": illegal operation on a directory
while executing
"gets $f s"
(procedure "UnoReadScores" line 14)
invoked from within
"UnoReadScores"
(file "scripts/uno.tcl" line 2402)
invoked from within
"source scripts/uno.tcl"
(file "unobot.conf" line 107)
* FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)


Que puis-je faire pour résoudre ce probleme ?

Merci d'avance pour vos réponses.
#2
Bonjour,

N'y a-t-il pas un dossier à créer, genre "scores" pour que le tcl puisse y stocker les scores ?

Tout n'est peut être pas installé pour les scores.
#3
Et bien si il faut un dossier scores j'ai essayer de le mettre dans script et j'ai aussi essayer de le mettre dans le dossier de l'eggdrop mais ya tjrs une erreur

voici ce qu'il y a dans le uno.tcl
set UnoCFGFile "scripts/uno.cfg"
set UnoScoreFile "scripts/scores/UnoScores"

la je l'ai refait et j'ai pas la même erreur

Tcl error in file 'unobot.conf':
[15:28] couldn't open "scores/UnoScores": no such file or directory
while executing
"open $UnoScoreFile w"
invoked from within
"if ![file exists $UnoScoreFile] {
set f [open $UnoScoreFile w]
puts $f "$UnoRobot 0 0"
close $f
}"
(procedure "UnoReadScores" line 7)
invoked from within
"UnoReadScores"
(file "scripts/uno.tcl" line 2402)
invoked from within
"source scripts/uno.tcl"
(file "unobot.conf" line 107)
[15:28] * FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)
#4
Quote:Tcl error in file 'unobot.conf':
[15:28] couldn't open "scores/UnoScores": no such file or directory

On dirait qu'il ne peut effectivement ouvrir ce répertoire manquant.

Tenter de créer le répertoire "scores" à la racine de l'eggdrop, mais pas dans script.

Mettre :
set UnoCFGFile "scripts/uno.cfg"
set UnoScoreFile "scores/UnoScore"
#5
Bonsoir , vas dans uno.cfg et change la direction dedans et indique celle ou est le fichier de UnoScores :)
#6
Encore une chose , si tu change le uno de salon ,cchane le nom de salon aussi dans le cfg :)voila :)
#7
Merci pour vos réponses, sa marche mais qu'avec une version anglaise, la version francaise m'indique une erreur

invalid command name "#"
while executing
"#"
(file "scripts/uno.tcl" line 1)
invoked from within
"source scripts/uno.tcl"
(file "unobot.conf" line 107)
* FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)

Donc je vais traduire la version Anglaise sa m'occupera un moment.

Merci encore
#8
bonjour,

alors pour ce qui est de ton erreur
Quote:invalid command name "#"
while executing
"#"

vérifie si à coter d'un # tu na pas ce genre de caractère ! ou alors cela peut venir du tcl de blacklist
ici

qui n'est pas pour eggdrop mais plutôt pour Xchat ..


cordialement
La différence entre Linux et Windows ,c'est que Linux c'est comme une belle fille , il faut l'apprivoiser , la comprendre , la séduire tandis que Windows , c'est comme une prostitué , il faut payer et surtout bien se protéger.
#9
Bonjour,

J'ai téléchargé le uno sur windrop1.6.19 , au début il ne fonctionnait pas ,j'ai fait le changement:

set UnoCFGFile "scripts/uno.cfg"
set UnoScoreFile "scores/UnoScore"



comme indiqué au dessus ;et ça fonctionne trés bien .Merci pour vos renseignements.
Ce que tu gardes est perdu à jamais. Ce que tu donnes est à toi pour toujours.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Problème avec Les poupées linkeuses zappeur78 22 5,402 31/03/2022, 16:52
Last Post: CrazyCat
  [Résolu] Problème avec le script autolog T3nS 2 3,195 06/12/2017, 16:08
Last Post: T3nS
  [Bug] Problème avec le script zurl.tcl T3nS 0 3,031 03/08/2017, 19:40
Last Post: T3nS
  [Résolu] Problème d'accents avec script TCL maison CC30 3 4,681 25/08/2016, 13:55
Last Post: Alucard`68
  [Résolu] Problème d'encodage avec rss-synd Naruto 24 13,542 18/05/2014, 21:16
Last Post: CrazyCat
  Problème avec Clams SaiTek 7 5,817 06/09/2013, 09:02
Last Post: SaiTek
  Problème d'accent avec shoutcast.tcl Naruto 8 6,670 05/08/2013, 15:17
Last Post: Naruto
  [Résolu] [Aide]Problème avec un tcl Naruto 6 5,875 17/07/2013, 20:56
Last Post: CrazyCat
  probleme avec mon script Nostromo1st 7 6,007 05/06/2013, 09:51
Last Post: Nostromo1st
  probleme avec regsub Nostromo1st 2 4,423 03/06/2013, 10:30
Last Post: Nostromo1st

Forum Jump:


Users browsing this thread: 1 Guest(s)