Communauté sur les Eggdrops - Community about Eggdrops
soucis avec mon windop.tcl - Printable Version

+- Communauté sur les Eggdrops - Community about Eggdrops (https://forum.eggdrop.fr)
+-- Forum: Eggdrop et TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=8)
+--- Forum: Scripts TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=4)
+--- Thread: soucis avec mon windop.tcl (/showthread.php?tid=917)



soucis avec mon windop.tcl - mcsaturn - 23/03/2011

Bonjour a tous. voici mon problème
j'ai lancé deux eggdrop depuis le même dossier jusqu'a maintenant, cela fonctionnais très bien mais depuis une deco du serveur ce matin, impossible de relancer mon deuxieme eggdrop

voici mon erreur sous putty :


[09:17:29] invalid command name "putserv"
while executing
"putserv "JOIN $xcservice(chan)""
(procedure "CService" line 3)
invoked from within
"CService"
(file "scripts/windop2.tcl" line 217)
invoked from within
"source scripts/windop2.tcl"
(file "baboune.conf" line 106)
[09:17:29] * FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)


quelqu'un aurait une idée pour ce problème ? merci beaucoup


RE: soucis avec mon windop.tcl - mcsaturn - 23/03/2011

mon erreur se trouve dans ses lignes la :

tcl
# Commande établie à la connection au serveur avec l'Enregistrement de la salle # d'administration.
 
foreach dc [dcclist] { if {[lindex [lindex $dc 4] 1] == "CServiceEvent"} {killdcc [lindex $dc 0]} }
CService
channel add $xcservice(chan) {
  chanmode "$xcservice(modechanadmin)"
  idle-kick 0
  stopnethack-mode 0
  revenge-mode 1
  aop-delay 5:30
  need-invite { putquick "PRIVMSG $xcservice(chan) :Laissez moi entrer dans $xcservice(chan)" }
  need-key { putquick "PRIVMSG $xcservice(chan) :Laissez moi entrer dans $xcservice(chan)" }
  need-unban { putquick "PRIVMSG $xcservice(chan) :Laissez moi entrer dans $xcservice(chan)" }
  need-limit { putquick "PRIVMSG $xcservice(chan) :Laissez moi entrer dans $xcservice(chan)" }
  flood-chan 30:5
  flood-deop 10:5
  flood-kick 5:5
  flood-join 10:5
  flood-ctcp 5:5
  flood-nick 5:5
}


Edit par CrazyCat: merci d'utiliser les balises [ tcl ] et [ /tcl ]


RE: soucis avec mon windop.tcl - mcsaturn - 23/03/2011

bon j'ai avancer dans la config mais maintenant voici mon autre soucis :


[11:13:31] * Last context: tclhash.c/242 []
[11:13:31] * Please REPORT this BUG!
[11:13:31] * Check doc/BUG-REPORT on how to do so.
[11:13:31] * Wrote DEBUG
[11:13:31] * SEGMENT VIOLATION -- CRASHING!
Segmentation fault


et dans le debug :


Debug (eggdrop v1.6.20) written Wed Mar 23 10:59:58 2011
Full Patch List:
Tcl library: /usr/share/tcltk/tcl8.4
Tcl version: 8.4.19 (header version 8.4.19)
Tcl is threaded
Compile flags: gcc -g -O2 -pipe -Wall -I.. -I.. -DHAVE_CONFIG_H
Link flags: gcc
Strip flags: touch
Context: main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
main.c/948, []
tclhash.c/218, []
tclhash.c/242 []

SOCK ADDR PORT NICK HOST TYPE
---- -------- ----- --------- ----------------- ----
3 00000000 0 (dns) dns (ready)
4 5762BD9B 3000 (telnet) * lstn 3000

Compiled without extensive memory debugging (sorry).
Open sockets: 3 (passed on), 4 (listen), 6 (file), done.