Communauté sur les Eggdrops - Community about Eggdrops
Trivia des questions - Printable Version

+- Communauté sur les Eggdrops - Community about Eggdrops (https://forum.eggdrop.fr)
+-- Forum: Eggdrop et TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=8)
+--- Forum: Scripts TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=4)
+--- Thread: Trivia des questions (/showthread.php?tid=557)



Trivia des questions - kipof - 24/11/2009

Bonsoir,
Le titre du sujet semble bizard mais non, mes questions ont surement déjà été poser mais je trouve pas mes réponses ou presque.
alors je commence, Les réponses qui ont des caractères avec accents le bot ne vois rien ( domage ) voice ce que j'ai pour les accents sur le script :

tcl
proc mx_tweak_umlauts {texts} {
regsub -all {(([0-9])?([0-9])?(\,([0-9])?([0-9])?)?)?} $texts "" texts
regsub -all {([0-9A-F][0-9A-F])?} $texts "" texts
regsub -all \{|\} $texts "" texts
regsub -all \002 $texts "" texts
regsub -all \037 $texts "" texts
regsub -all  $texts "" texts
regsub -all  $texts "" texts
regsub -all  $texts "" texts
regsub -all  $texts "" texts
regsub -all  $texts "" texts
regsub -all  $texts "" texts
regsub -all "A" $texts "a" texts
regsub -all "B" $texts "b" texts
regsub -all "C" $texts "c" texts
regsub -all "D" $texts "d" texts
regsub -all "E" $texts "e" texts
regsub -all "F" $texts "f" texts
regsub -all "G" $texts "g" texts
regsub -all "H" $texts "h" texts
regsub -all "I" $texts "i" texts
regsub -all "J" $texts "j" texts
regsub -all "K" $texts "k" texts
regsub -all "L" $texts "l" texts
regsub -all "M" $texts "m" texts
regsub -all "N" $texts "n" texts
regsub -all "O" $texts "o" texts
regsub -all "P" $texts "p" texts
regsub -all "Q" $texts "q" texts
regsub -all "R" $texts "r" texts
regsub -all "S" $texts "s" texts
regsub -all "T" $texts "t" texts
regsub -all "U" $texts "u" texts
regsub -all "V" $texts "v" texts
regsub -all "W" $texts "w" texts
regsub -all "X" $texts "x" texts
regsub -all "Y" $texts "y" texts
regsub -all "Z" $texts "z" texts
regsub -all "à" $texts "a" texts
regsub -all "â" $texts "a" texts
regsub -all "è" $texts "e" texts
regsub -all "È" $texts "E" texts
regsub -all "é" $texts "e" texts
regsub -all "É" $texts "E" texts
regsub -all "ê" $texts "e" texts
regsub -all "Ê" $texts "e" texts
regsub -all "ë" $texts "e" texts
regsub -all "Ë" $texts "e" texts
regsub -all "à" $texts "a" texts
regsub -all "À" $texts "a" texts
regsub -all "â" $texts "a" texts
regsub -all "Â" $texts "a" texts
regsub -all "ç" $texts "c" texts
regsub -all "ô" $texts "o" texts
regsub -all "Ô" $texts "o" texts
regsub -all "ù" $texts "u" texts
regsub -all "Ù" $texts "u" texts
regsub -all "û" $texts "u" texts
regsub -all "Û" $texts "u" texts
regsub -all "ü" $texts "u" texts
regsub -all "í" $texts "u" texts
regsub -all "ï" $texts "i" texts
regsub -all "Ï" $texts "i" texts
regsub -all "î" $texts "i" texts
regsub -all "Î" $texts "i" texts
regsub -all "ì" $texts "i" texts
regsub -all "í" $texts "i" texts
set text [string trimleft $texts]
set lastchar [string index $text [expr [string length $text] -1]]
if {[string compare $lastchar "\\"] == 0} {
regsub -all {\\} $text "" newarg
append newarg "\\"
set text $newarg
}
return $text
}




Et ensuite j'ai cherché des réponses pour les points variable et je suis tombé sur ce sujet : http://www.eggdrop.fr/board/Triviatcl-Points-variables-t-471-1.html#pid2860

Je sais pas si je fait la chose comme elle doit être faite mais cela me plante un peux les scores :/

Si vous aurriez deux trois petit conseils cela serais sympa :).

Merci d'avance kipof.


RE: Trivia des questions - BdS - 25/11/2009

Pour les accents dans les réponses, j'ai ce code dans mon trivia:


tcl
proc no_accent {code_text} {
   regsub -all é $code_text "e" code_text
   regsub -all è $code_text "e" code_text
   regsub -all ê $code_text "e" code_text
   regsub -all ï $code_text "i" code_text
   regsub -all ï $code_text "i" code_text
   regsub -all ù $code_text "u" code_text
   regsub -all ô $code_text "o" code_text
   regsub -all ç $code_text "c" code_text
   regsub -all à $code_text "a" code_text
   regsub -all â $code_text "a" code_text
   return $code_text
}


Pour ce qui est des points variables, la page que tu cites te donnes la réponse. Donnes nous les erreurs que tu as en partyline ou ce que tu appelles "planter un peu les scores".


RE: Trivia des questions - kipof - 25/11/2009

Pour les accents même problème avec ce code et pour les points variable c'est surement la ligne que je colle au mauvais endroit :/

dans la proc tgcorrectanswer que j'ajoute la ligne mais je pense faire une erreur car il me crée d'autre comptes scores :p


tcl
#déclenché quand quelqu'un dit la réponse correcte.
proc tgcorrectanswer {nick} {
    global tgcurrentanswer tghinttimer tgtimenext tgchan tgnextqtimer tgstreak tgstreakmin
    global tgscoresbyname tgranksbyname tgranksbynum tgcongrats tgscorestotal tgmissed
    global tgtimestart tgshowallscores tgrealnames tgscoresbyrank tgtimeanswer tgmulti
    tggetscores
    if {![info exists tgranksbyname([strlwr $nick])]} {
        set _oldrank 0
    } else {
        set _oldrank $tgranksbyname([strlwr $nick])
    }
    tgincrscore $nick[lindex $::tganswscore $::tghintnum]
    tggetscores
    set _newrank $tgranksbyname([strlwr $nick])
    set _timetoanswer ""
    if {$tgtimeanswer==1} {
        set _timetoanswer [expr [expr [clock clicks -milliseconds]-$tgtimestart]/1000.00]
    }
	if !([isvoice $nick $tgchan]||[isop $nick $tgchan]) {
			putserv "MODE $tgchan +v $nick"
	}




RE: Trivia des questions - BdS - 25/11/2009

Au pire fait ça:
Romu83 Wrote:bonjour CrazyCat!

ne te casse pas la tete avec l'histoire des points variables, en regardant plus en detail votre forum, j'ai remarqué qu'une trivia tcl en francais etait dispos en telechargement chez vous, donc je l'ai prise, configurer et tester elle marche nikel et en plus les points variables sont inclus.

merci a toi
Romu83

et a mon avis tu n'auras plus de probleme avec les accents.


RE: Trivia des questions - kipof - 25/11/2009

Il y'a que un trivia sur la page téléchargement, qui est presque le même que le mien, sauf si la personne parle du Jservice ?


RE: Trivia des questions - kipof - 26/11/2009

Bonsoir, j'ai test le JService mais le problème des accents reste :/ le accents.tcl serait-il utile pour ce genre de scripts ?

Merci.


RE: Trivia des questions - BdS - 27/11/2009

Je ne comprend pas. Tu ajoutes un morceau de code pour les accents ou tu as testé le script tel quel ? Est ce qu'il propose cette option ?
Le trivia qui est telechargeable sur ce site, propose l'option pour les accents (qui fonctionne très bien), et il me semble (j'ai parcouru le code rapidement) qu'il propose aussi des points variables par rapport au numero d'indice donné.

Tiens nous au courant si tu as des erreurs en pl, ça peut aider


RE: Trivia des questions - kipof - 27/11/2009

Bonsoir,
Enfaite j'utilise le même trivia qui se trouve ici mais d'une version plus vielle. Donc j'ai ajouté la fonction qui se trouve sur le votre pour les accents et j'ai bien modifier toutes les lignes contenant le no_accent mais pareil :/ l'eggdrop vois pas les accents.. Par la suite je me suis dis que je dois surement faire une erreur et j'ai donc pris le JService qui prend aussi les accents avec les points variable mais pareil ( je suis modis :p ) maintenant je viens de test le votre et il est vrai que les points sont aussi variable ( merci BsD de me l'avoir fait remarqué ) mais mon malheure continue le bot vois pas les accents :( et pas d'erreurs en dcc chat :/ une petite idée ? je sèche.
EDIT:

Un test avec votre trivia qui se trouve en téléchargement, les caractères change au première indice comme l'indique le screen je sais pas si cela peux aidé à trouver mon problème mais je poste :

[Image: http://imagesup.org/images4/1259349732-capture-1.png]
Merci encore.


RE: Trivia des questions - CrazyCat - 27/11/2009

Et bien il y a tout simplement un énorme problème d'encodage au niveau des fichiers de l'eggdrop. Ou bien du client IRC, voire du serveur. Que tout le monde soit en UTF-8 et ça ira bien.


RE: Trivia des questions - kipof - 27/11/2009

Le serveur est en CASEMAPPING=rfc1459 Il me semble, je peux faire une modifications sur l'eggdrop pour cela ?


RE: Trivia des questions - kipof - 28/11/2009

J'ai remarqué que si je retire les accents des réponses, disont que la reponse serait helene et que l'on mais hélène le robot prend en compte la reponse :/ j'ai du mal a comprendre.