Communauté sur les Eggdrops - Community about Eggdrops
Auto-reop - Printable Version

+- Communauté sur les Eggdrops - Community about Eggdrops (https://forum.eggdrop.fr)
+-- Forum: Eggdrop et TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=8)
+--- Forum: Scripts TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=4)
+--- Thread: Auto-reop (/showthread.php?tid=392)



Auto-reop - bewess - 06/05/2009

Bonjour

J'aimerais savoir ce qui cloche dans ma syntaxe :
Quand mon bot plante ou autre j'aimerais qu'il se réop/invite a son arriver.
Voici ce que je tape en pl :
.console #salon
.chanset need-invite putserv "privmsg bot: invite monpass #salon"
.chanset need-op putserv "privmsg bot: op monpass #salon"
.chansave
.rehash ou .restart

D'ou vient mon erreur svp
Sinon quelqu'un aurait l'équivalent en tcl ?
merci


RE: Auto-reop - CrazyCat - 06/05/2009

Je présume que "bot" dans tes privmsg correspond au nick du robot de service (et pas à l'eggdrop).
Je pense que tu te trompes avec la syntaxe des needs:

Code:
.chanset #salon need-invite putserv "privmsg bot: invite monpass #salon"
.chanset #salon need-op putserv "privmsg bot: op monpass #salon"
Tu peux ensuite vérifier avec:

Code:
.chaninfo #salon



RE: Auto-reop - bewess - 06/05/2009

ca marche pas j'avais deja essayer
et pas de message d'erreur :s
oui bot = le robot du service


RE: Auto-reop - CrazyCat - 06/05/2009

Vérifies la syntaxe des messages envoyés, ainsi que les destinataires.
Je pencherais plutôt pour des envois à chanserv (et non pas au service sur le canal).


RE: Auto-reop - bewess - 09/05/2009

bonjour
cela ne marche toujours pas :(


RE: Auto-reop - fedora - 09/05/2009

bonjour,

peut tu nous dire quel robot ton bot doit t'il ce reop ?