Communauté sur les Eggdrops - Community about Eggdrops
[Bug] Connexion services Tisma - Printable Version

+- Communauté sur les Eggdrops - Community about Eggdrops (https://forum.eggdrop.fr)
+-- Forum: Eggdrop et TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=8)
+--- Forum: Scripts TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=4)
+--- Thread: [Bug] Connexion services Tisma (/showthread.php?tid=1740)



Connexion services Tisma - Kookie - 23/12/2019

Bonjour,

Voulant réinstaller les services Tisma (Eva, Lea, Talis, Oz, Geofront, etc...) je n'arrive pas à activer les liens.

Pour des raisons de sécurité des mots de passes bidons on été set dans ce topic. Ils sont donc en l'état, inutilisables. 

Voici le résultat de la connexion après que soit connecté l'eggdrop supportant les services Tisma :
Quote:-
05[20:24:30] -Cyber.Tchat- Link denied for Geo.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Geo.Cyber.Tchat') [cybertchat@91.191.147.138.39172]
-
05[20:24:30] -Cyber.Tchat- Link denied for Oz.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Oz.Cyber.Tchat') [cybertchat@91.191.147.138.48106]
-
05[20:24:30] -Cyber.Tchat- Link denied for Talis.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Talis.Cyber.Tchat') [cybertchat@91.191.147.138.43406]
-
05[20:26:01] -Cyber.Tchat- Link denied for Geo.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Geo.Cyber.Tchat') [cybertchat@91.191.147.138.50593]
-
05[20:26:01] -Cyber.Tchat- Link denied for Oz.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Oz.Cyber.Tchat') [cybertchat@91.191.147.138.42186]
-
05[20:26:01] -Cyber.Tchat- Link denied for Talis.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Talis.Cyber.Tchat') [cybertchat@91.191.147.138.59755]
-

Alors que dans le .conf :


Code:
ulines {
services.cyber-tchat.fr;
stats.cyber-tchat.fr;
67.215.11.198;
linked.irc.net;
Geo.Cyber.Tchat
Oz.Cyber.Tchat
Lea.Cyber.Tchat
Eva.Cyber.Tchat
Thalis.Cyber.Tchat
};

link Geo.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Oz.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Lea.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Eva.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Talis.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};
Et sur chaque .conf des services :

Code:
######################
# Configuration Link #
######################

#--> Adresse du link
set eva(link) "Eva.Cyber.Tchat"

#--> Ip du link
set eva(ip) "91.191.147.138"

#--> Port du link
set eva(port) "7000"

#--> Mot de passe du link
set eva(pass) "12345"

#--> Infos du link
set eva(info) "Eva Service"

Vous avez une idée à me proposer pour m'aider s'il vous plaît ?


RE: Connexion services Tisma - ksao - 23/12/2019

yop,

tu as oublié des ; au niveau de tes ulines, normalement lors de ton rehash tu dois avoir un retour d'erreur.


Code:
ulines {
services.cyber-tchat.fr;
stats.cyber-tchat.fr;
67.215.11.198;
linked.irc.net;
Geo.Cyber.Tchat;
Oz.Cyber.Tchat;
Lea.Cyber.Tchat;
Eva.Cyber.Tchat;
Thalis.Cyber.Tchat;
};
Il faut que tu nous montres aussi ta configuration au niveau des links.

Il faut fournir plus d'informations, version d'unrealircd ?


RE: Connexion services Tisma - Kookie - 29/12/2019

J'ai corrigé, mais rien n'a changé

La version est UnrealIRCd-4.2.4.1

Les links sont dans le code des ulines (scroll down :P)


RE: Connexion services Tisma - CrazyCat - 29/12/2019

Tu utilises hostname 127.0.0.1; dans unreal et set eva(ip) "91.191.147.138" dans ton TCL...
Tu devrais vérifier aussi les logs d'unreal qui doivent te dire pourquoi la connexion est rejetée.