Communauté sur les Eggdrops - Community about Eggdrops
[Résolu] msgcat, soucis de format. - Printable Version

+- Communauté sur les Eggdrops - Community about Eggdrops (https://forum.eggdrop.fr)
+-- Forum: Eggdrop et TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=8)
+--- Forum: Scripts TCL (https://forum.eggdrop.fr/forumdisplay.php?fid=4)
+--- Thread: [Résolu] msgcat, soucis de format. (/showthread.php?tid=1541)



msgcat, soucis de format. - aliasangelius - 28/06/2014

Bonjour,

Je me permet de venir vous demander de l'aide..
Je me retrouve sur une incompréhension, j'ai beau chercher je ne trouve pas.

Je vous explique mon problème.
Lorsque j'ai mets sockets qui se connect au serveur, elle dises un Wallops.
Jusque là pas de soucis.

Mais dans le message transmis j'ai ceci : [12:15:42] !IriX! Service IriX Ù Connecté.

Donc j'ai ce fameux Ù, Qui sort de je ne sais pas ou..

Je vous montre le message de msgcat :


tcl
namespace eval ::socks {
	variable OperServ
 
	# Nous vérifions si y'a le package requis pour le msgcat.
	package require msgcat
	# Nous mettons la langue de msgcat en français.
	::msgcat::mclocale fr
	# Les messages msgcat.
	# Les Wallops.
	::msgcat::mcset fr WIriX "\0031Service \037\0034%s \037 \331 Connecté.\0031"


La variable de IriX :


tcl
# IriX
set OperServ(nicki) "IriX"


Et pour finir le putdcc :


tcl
putdcc $OperServ(idx) ":$OperServ(nicki) WALLOPS :[::msgcat::mc WIriX $OperServ(nicki)]"


Donc, à moins que j'ai omis de faire quelque chose, je ne vois pas d'ou proviens le soucis.
Si quelqu'un pourrais m'aidez sa serait sympa :)


RE: msgcat, soucis de format. - aliasangelius - 28/06/2014

Soucis résolu.

J'avais mis 331 en code couleurs, au lieu de 0031.
Merci CrazyCat de m'avoir guider, et Killer pour les tests.


RE: msgcat, soucis de format. - BaGrift - 28/06/2014

Pas de soucis avec plaisir