Bienvenue, Visiteur
Vous devez vous enregistrer avant de pouvoir poster.

Nom d’utilisateur
  

Mot de passe
  





Rechercher dans les forums



(Recherche avancée)

Statistiques du Forum
» Membres : 730
» Dernier membre : Gi2312
» Sujets du forum : 1,543
» Messages du forum : 11,601

Statistiques complètes

Derniers sujets
ChanRelay 3 (version 3.14...
Forum : Releases et support
Dernier message : CrazyCat
23/06/2020, 16:14
» Réponses : 23
» Affichages : 14,904
blackjack.tcl
Forum : Eggdrop
Dernier message : CrazyCat
23/06/2020, 11:49
» Réponses : 10
» Affichages : 1,391
ouverture d'un fichier
Forum : Scripts TCL
Dernier message : CrazyCat
21/06/2020, 18:29
» Réponses : 1
» Affichages : 149
Aide pour chanrelay
Forum : Un peu plus loin
Dernier message : CrazyCat
20/06/2020, 17:50
» Réponses : 3
» Affichages : 285
Reanimator (version actue...
Forum : Releases et support
Dernier message : Daneel
12/06/2020, 11:08
» Réponses : 30
» Affichages : 12,843
Eggdrop et Unreal5.0.4
Forum : Eggdrop
Dernier message : DaDIsS
09/06/2020, 02:37
» Réponses : 10
» Affichages : 302
"::http::register https 4...
Forum : Scripts TCL
Dernier message : DaDIsS
07/06/2020, 18:55
» Réponses : 12
» Affichages : 818
TCL de fermture
Forum : Scripts TCL
Dernier message : CrazyCat
07/06/2020, 01:05
» Réponses : 1
» Affichages : 186
Problème eva.tcl
Forum : Scripts TCL
Dernier message : ShowDowN
06/06/2020, 11:24
» Réponses : 5
» Affichages : 217
[fractionné] configuratio...
Forum : Eggdrop
Dernier message : CrazyCat
01/06/2020, 00:35
» Réponses : 1
» Affichages : 208

 
  Problème d'encodage charset suite à changement de version
Posté par : exactkayak - 06/02/2020, 00:00 - Forum : Scripts TCL - Réponses (3)

TL;DR - "œ ç é à è ù â ê î ô û ë ï ü" donne "Šç é à è ù â ê î ô û ë ï ü"

Bonjour à tous,

Mon hébergeur a mis fin à mon offre VPS et m'a demandé de passer sur un nouveau serveur. J'ai donc déménagé mon eggdrop et j'en ai profité pour passer de la version 1.6.21 à 1.8.4 en faisant une installation "fraîche" (oui, il était temps).

Hélas j'ai maintenant un problème d'encodage, alors que normalement la version 1.8 devrait gérer ça mieux que la 1.6. Suite à mes recherches, j'ai tout de même édité tcl.c (dans in eggdrop-1.8.4/src) et remplacé :

Code :
if (encoding == NULL) {
  encoding = "iso8859-1";
}

Par ceci :

Code :
if (encoding == NULL) {
  encoding = "iso8859-1";
  encoding = "utf-8";
}

Puis "make clean" et compilé à nouveau avant de relancer. Normalement ça c'est OK (une solution pour vérifier plus précisément ce point ?)

Je n'ai pas touché à mon code en Tcl, j'ai téléchargé mon ancien script en l'état sur le nouveau serveur pour être utilisé par l'eggdrop. Peut être quelque chose est à modifier à ce niveau ? Voici un exemple de ce qui fonctionnait avant cette réinstallation/passage à la nouvelle version :

tcl
bind pub - !utf8 pub:utf8 
proc pub:utf8 { nick uhost handle chan arg } {
pututf8 $chan "œ ç é à è ù â ê î ô û ë ï ü"
}
proc pututf8 { chan text } {
putserv "PRIVMSG $chan :[encoding convertto utf-8 $text]"
return 1
}



Maintenant le résultat donné est : Šç é à è ù â ê î ô û ë ï ü
Je ne peux que supposer que ce problème avec utf-8 est lié à mon script Tcl, le serveur IRC où l'eggdrop est connecté n'a lui pas changé et la précédente version y fonctionnait.

Au cas où Tcl pourrait être en cause, je vous donne cette info :
Code :
tclsh
% puts $tcl_version
8.6
% info patchlevel
8.6.6

Et si ça serait lié (mais peut être pas) j'ai aussi ce problème d'encodage au lancement :

Code :
Eggdrop v1.8.4 (C) 1997 Robey Pointer (C) 2010-2018 Eggheads
--- Loading eggdrop v1.8.4 (Wed Feb  5 2020)
Listening for telnet connections on -retiré- (all).
Module charg▒: blowfish
Module charg▒: dns
Module charg▒: channels
Module charg▒: server
Module charg▒: ctcp
Module charg▒: irc
Module charg▒: notes            (avec support internationnal)
Module charg▒: console          (avec support internationnal)
Loading dccwhois.tcl...
Loaded dccwhois.tcl
Userinfo TCL v1.07 loaded (URL BF GF IRL EMAIL DOB PHONE ICQ).
use '.help userinfo' for commands.
Nauth 2.1 by TiSmA©
Mybot
Writing channel file...
Userfile loaded, unpacking...
=== mybot: 3 channels, 1 users.
Launched into the background  (pid: 21284)

J'ai farfouillé sur le forum et ailleurs mais sans trouver de solutions autres que celles déjà en place comme mentionné ici.
Quelles pistes me conseillez vous d'explorer pour résoudre cela ? Je me tourne vers vous du coup ... Merci d'avance ! :)


  Youtube
Posté par : pheeric - 10/01/2020, 22:41 - Forum : Scripts TCL - Réponses (1)

Bonsoir et meilleurs vœux à toutes et tous :)

Un p'tit bug en PL en ce début d'année sur le tcl youtube :

Tcl error [public_youtubedl]: can't read "res1": no such variable

Auraient-ils a nouveau changé dans leurs liens ou cela peut venir d'ailleurs ?

Eggdrop1.6.21
OS: Linux 4.19-ovh-xxxx-std-ipv6-64
librairie Tcl: /usr/share/tcltk/tcl8.6
Tcl version: 8.6.2 (header version 8.6.2)
Tcl is threaded.

Merci a vous au cas ou :)
Bonne soirée


  [Spamfilter] Aide sur une regexp
Posté par : ksao - 06/01/2020, 03:21 - Forum : Services IRC - Réponses (1)

Déplacé: la regex est pour être utilisée avec spamfilter

hi,

Je travaille sur une regexp dans lequel je veux match 10 mots de 3 lettres minimum dans une phrase.

Quand je fais des tests :


Citation :.tcl regexp {.+?\s(\w{3}\s[^$]*\s){10,}} "vmy atjjt kmo bcqdd alwt dbe atp qbb ijm hndpov rga sbn rqmgw hox nkk rxkxu bvo whmcob qgv qou"


ça me retourne 0

alors que quand je change le 10 en 6 ça me retourne 1

Ma regexp doit être mauvaise, je me retourne vers vous :)


  Recherche Éva Léa Geo
Posté par : Shad0w - 05/01/2020, 12:09 - Forum : Scripts TCL - Réponses (1)

Bonjour je cherche les 3 Bot 
Léa Éva Géo
Comme les projet exolia inaccessible Y'a pas ou les télécharger donc 
Si quelqu'un peux les ajouter pour que je les télécharge Merci


  AIde dans une procédure
Posté par : ksao - 03/01/2020, 14:12 - Forum : Scripts TCL - Réponses (2)

bjr,

Voici ma procédure , je veux que le bot match des pays précis lors de sa connection tout fonctionne bien :


Code :
proc paysredirect {from key text} {

set text_elements [split $text]

        putlog "text_elements => $text_elements"

        lassign $text_elements {} nick {} {} pays

        ## Pays Match

        if {$pays eq "Chine"} {

            putlog "$nick / $pays"

        }

}


je veux crée une condition spécial pour des pays qui se connecte depuis une connexion qui ne provient pas du navigateur internet , donc si l'utilisateur provient du maroc n'est pas renvoyer ça le match.

J'éspère avoir été suffisamment clair dans mon explication, merci à vous :)


  Connexion services Tisma
Posté par : Kookie - 23/12/2019, 19:02 - Forum : Scripts TCL - Réponses (3)

Bonjour,

Voulant réinstaller les services Tisma (Eva, Lea, Talis, Oz, Geofront, etc...) je n'arrive pas à activer les liens.

Pour des raisons de sécurité des mots de passes bidons on été set dans ce topic. Ils sont donc en l'état, inutilisables. 

Voici le résultat de la connexion après que soit connecté l'eggdrop supportant les services Tisma :

Citation :-
05[20:24:30] -Cyber.Tchat- Link denied for Geo.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Geo.Cyber.Tchat') [cybertchat@91.191.147.138.39172]
-
05[20:24:30] -Cyber.Tchat- Link denied for Oz.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Oz.Cyber.Tchat') [cybertchat@91.191.147.138.48106]
-
05[20:24:30] -Cyber.Tchat- Link denied for Talis.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Talis.Cyber.Tchat') [cybertchat@91.191.147.138.43406]
-
05[20:26:01] -Cyber.Tchat- Link denied for Geo.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Geo.Cyber.Tchat') [cybertchat@91.191.147.138.50593]
-
05[20:26:01] -Cyber.Tchat- Link denied for Oz.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Oz.Cyber.Tchat') [cybertchat@91.191.147.138.42186]
-
05[20:26:01] -Cyber.Tchat- Link denied for Talis.Cyber.Tchat(cybertchat@91-191-147-138.tismania.org) (No link block named 'Talis.Cyber.Tchat') [cybertchat@91.191.147.138.59755]
-

Alors que dans le .conf :

Code :
ulines {
services.cyber-tchat.fr;
stats.cyber-tchat.fr;
67.215.11.198;
linked.irc.net;
Geo.Cyber.Tchat
Oz.Cyber.Tchat
Lea.Cyber.Tchat
Eva.Cyber.Tchat
Thalis.Cyber.Tchat
};

link Geo.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Oz.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Lea.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Eva.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

link Talis.Cyber.Tchat { 
password "12345"; 
class servers;
        incoming {
                mask *@*;
        };
        outgoing {
                bind-ip *;
                hostname 127.0.0.1;
                port 7000;
        };
};

Et sur chaque .conf des services :
Code :
######################
# Configuration Link #
######################

#--> Adresse du link
set eva(link) "Eva.Cyber.Tchat"

#--> Ip du link
set eva(ip) "91.191.147.138"

#--> Port du link
set eva(port) "7000"

#--> Mot de passe du link
set eva(pass) "12345"

#--> Infos du link
set eva(info) "Eva Service"


Vous avez une idée à me proposer pour m'aider s'il vous plaît ?


  configuration pisg
Posté par : daniels - 29/11/2019, 12:15 - Forum : Services IRC - Réponses (6)

bonjour,
j'ai besoin d'aide pour la configuration de pisg.
voici ce que j'ai quand je le lance en ssh:

(vortex)(~/pisg)-> ./pisg
pisg v0.72 - Perl IRC Statistics Generator

Using config file: pisg.cfg

Statistics for channel #friedszone @ irc.friendszone.be by Master

Looking for logfiles in /home/vortex/eggdrop/logs/...

2 logfile(s) found, using eggdrop format...

Analyzing log /home/vortex/eggdrop/logs/#friendszone.log.20191128... 0 days, 0 lines total
Analyzing log /home/vortex/eggdrop/logs/#friendszone.log.20191129... 0 days, 0 lines total
Channel analyzed successfully in 00 hours, 00 minutes and 00 seconds on Fri Nov 29 11:27:59 2019

No parseable lines found in logfile (30 total lines). Skipping.
-> You might be using the wrong format.
-> A common error is that the logs do not contain timestamps for each line.
(vortex)(~/pisg)->


merci pour votre aide


  configuration eggdrop 1.8.4
Posté par : daniels - 27/11/2019, 16:16 - Forum : Eggdrop - Réponses (2)

Bonjour, je vient d'installer eggdrop-1.8.4  et quand je veux le lancer avec ./eggdrop -m j'ai ceci :

(vortex)(~/eggdrop)-> ./eggdrop -m

Eggdrop v1.8.4 © 1997 Robey Pointer © 2010-2018 Eggheads
--- Loading eggdrop v1.8.4 (Wed Nov 27 2019)
* Please make sure you edit your config file completely.
(vortex)(~/eggdrop)->


quelqu'un sais ce que je devrait verifier?

je vous remercie d'avance pour votre aide


Exclamation Retour du wiki et cassage de thème
Posté par : CrazyCat - 22/11/2019, 15:02 - Forum : Annonces - Réponses (3)

Hello à tous

J'ai enfin pu reconstruire le wiki: https://wiki.eggdrop.fr, et sans aucune perte !

Par contre, une opération de maintenance a abimé le thème du forum. En fait il était abimé depuis la migration mais il était resté en cache, ce n'est plus le cas.
Donc ce week-end, opération d'upgrade du forum et remise en état de son apparence, peut-être avec de fortes modifications.


  Eggdrop join salon
Posté par : Another - 13/11/2019, 00:03 - Forum : Eggdrop - Réponses (6)

Bonjour,

Comment est-il possible de faire pour que lorsqu'un utilisateur rejoint un salon non enregistré, l'eggdrop le rejoint également ?

Merci d'avance.