Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


Problème commande JService
#1
Bonsoir,

J'ai installez sur mon serveur le quizz JService il est correctement configuré (sans link) mais quand je tape !quizz sa ne fonctionne pas et en PL j'ai se message d'erreur:

Code:
[00:19:01] <GamerZ> [00:19:02] Tcl error [xjstart]: can't read "xjservice(startop)": no such element in array
J'ai chercher sur les différent sujet ais je n'ai rien trouvé concernant cette erreur...

Merci de votre aide future.

PS: Je reçois bien le pv du bot quand on rentre sur le salon pour me dire que le quizz est désactivé etc...
Cordialement
#2
J'ai modifier une ligne du code:

tcl
# Commande permettant de lancer le quizz.
set xjcmdstart "!quizz"
# Accé nécessaire pour LANCER le Quizz (à configurer dans la party line sur eggdrop).
set xjflagsstart "-|-"

par

tcl
# Commande permettant de lancer le quizz.
set xjcmdstart "!quizz"
# Accé nécessaire pour LANCER le Quizz (à configurer dans la party line sur eggdrop).
set xjflagsstart "o|o"

j'ai plus de message d'erreur en pl mais quand je lance le quizz voila se qui s'affiche:

Code:
[15:07:01] ‹@AngeDesOmbres› !quizz
[15:07:02] ‹@GamerZ› Le Quizz à Thème Cinema a été activé par AngeDesOmbres!
mais il y a aucune question qui s'affiche ...
Comment faire ?
Sinon comment dois-e m'i prendre pou configurer l'accès en PL ?

Cordialement.
#3
Personne pour m'aiguiller ?

Cordialement.
#4
Ce problème a déjà été abordé et résolu. Fais une recherche sur le forum.

D'autres quiz utilisent un code plus ou moins similaire à JService, alors si une recherche sur JService ne donne rien, élargis ta recherche aux autres quiz.
Toute l'actualité de mes scripts ici     (dernière mise à jour le 22/04/2020)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
#5
Salut,

Je ne connais pas le code "Quizz JService"
Si tu fournis un lien ou si tu met en pièce jointe de l'orignal (sans tes modifications dans le codes),
Je pourrais le teste ainsi voir si j'ai le même erreur que toi et peut être te le résoudre.

Cordialement,
ZarTek KrewKaite
Retrouvez les dernières versions de mes scripts TCL et bien plus sur ma page GitHub Cool


Possibly Related Threads…
Thread Author Replies Views Last Post
  probleme de commande sur KAOS loulou7593 43 26,131 30/03/2016, 23:44
Last Post: ShowDowN
  erreur jservice.tcl tzero 6 7,619 23/07/2013, 12:30
Last Post: Helias
Sad problème sur certaine commande Alucard`68 12 6,646 22/05/2012, 12:13
Last Post: Alucard`68
  Probleme de commande quizz loulou7593 13 22,951 03/01/2012, 22:31
Last Post: loulou7593
  JService ArKeNiS 2 3,851 24/04/2011, 16:08
Last Post: MenzAgitat
  Jservice.tcl Helias 0 3,240 08/08/2010, 10:48
Last Post: Helias
  Probleme avec commande AJOUT d'users loulou7593 13 8,323 10/07/2010, 18:57
Last Post: CrazyCat
  Probleme sur une !commande heretoc 3 4,616 22/06/2009, 15:54
Last Post: heretoc

Forum Jump:


Users browsing this thread: 1 Guest(s)