Impossible de config eggdrop 1.6.21 sous debian 9
#1
Bonjour, 

voila j'ai un serveur chez moi, tout est mis a jour niveau serveur, seulement lorsque je fait un ./configure voila l'erreur: 

configure: error:

  Tcl cannot be found on this system.

  Eggdrop requires Tcl and the Tcl development files to compile.
  If you already have Tcl installed on this system, make sure you
  also have the development files (common package names include
  'tcl-dev' and 'tcl-devel'). If I just wasn't looking
  in the right place for it, re-run ./configure using the
  --with-tcllib='/path/to/libtcl.so' and
  --with-tclinc='/path/to/tcl.h' options.

  See doc/COMPILE-GUIDE's 'Tcl Detection and Installation' section for more
  information.

kevin@serveur-1:~/bot/X/eggdrop1.6.21$

Et lorsque je fais un : ./configure --with-tclinc='/Library/Frameworks/Tcl.framework/Versions/8.6/Headers/tcl.h' --with-tcllib='/Library/Frameworks/Tcl.framework/Versions/8.6/libtclstub8.6.a'


voila sequ'il me dit : 

configure: WARNING:

  The file '/Library/Frameworks/Tcl.framework/Versions/8.6/libtclstub8.6.a' given to option --with-tcllib is not valid.
  Specify the full path including the file name (e.g. /usr/lib/libtcl8.5.so)

  configure will now attempt to autodetect both the Tcl library and header.

checking for Tcl library... not found
checking for Tcl header... found /usr/include/tcl8.5/tcl.h
checking whether the Tcl system has changed... yes
configure: error:

  Tcl cannot be found on this system.

  Eggdrop requires Tcl and the Tcl development files to compile.
  If you already have Tcl installed on this system, make sure you
  also have the development files (common package names include
  'tcl-dev' and 'tcl-devel'). If I just wasn't looking
  in the right place for it, re-run ./configure using the
  --with-tcllib='/path/to/libtcl.so' and
  --with-tclinc='/path/to/tcl.h' options.

  See doc/COMPILE-GUIDE's 'Tcl Detection and Installation' section for more
  information.

kevin@serveur-1:~/bot/X/eggdrop1.6.21$

A savoir tout est installer.

tcl tcl-dev tcllib et tcl8.5 tcl8.5-dev 

Il y a quelque semaine chez LWS j'avais un VPS sous debian 9 tout passer nickel mais plus maintenant.
  Répondre   Avertir
#2
Si ton système est mis à niveau, c'est tcl8.6 et tcl8.6-dev qu'il faut mettre, tu as dû figer tes paquets sur la 8.5.
Penses aussi à nettoyer tes tentatives de configuration et faire un make clean avant de retenter la compilation.
Et tu devrais passer en eggdrop 1.8.4, le 1.6.21 fait de plus en plus d'erreurs de compilation.
  Répondre   Avertir


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  [Bug] Impossible de compiler eggdrop sous Mac OS X pchevee 7 3,859 13/12/2015, 21:12
Dernier message: pchevee
  impossible de me connecter en ctcp ou dcc titguns 7 5,334 20/03/2012, 01:46
Dernier message: aliasangelius
  Connexion DCC CHAT avec mon eggdrop impossible. tow 1 3,892 27/01/2011, 18:41
Dernier message: Helias
  impossible de démarré mon eggdrop lesny 10 4,754 22/11/2010, 17:18
Dernier message: N3bIlIm
  ctcp impossible lesny 4 3,149 30/07/2010, 02:38
Dernier message: lesny
  flags possibles sous eggy pheeric 7 3,157 24/07/2010, 14:07
Dernier message: CrazyCat
  [debian 5] lancement eggdrop impossible blackdevil 16 7,089 09/04/2010, 23:35
Dernier message: blackdevil

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)