Erreur sur ovh pour installation
#1
bonjour à tous ,

apres plus de 10 ans sans y toucher j'ai decidé hier de remettre le nez dans les eggdrops Very Happy
j'ai donc recuperé un des dernier et mis sur mon mutua ovh

via putty j'ai lancé l'installation
mais je bloque sur

Citation :./configure --prefix=/home/votre-compte/shell/eggdrop

Citation :Donc nous faisons : cd eggdrop1.6.21rc1
Ceci nous permet d'aller dans le dossier de l'eggdrop qu'on désire.
Ensuite nous tapons : ./configure --prefix=/home/votre-compte/lebot
Remplacer : votre-compte <= par le nom de votre Shell.
Remplacer : lebot <= par le nom du dossier de l'eggdrop que vous désirez.

ca me retourne une erreur et l'installation se bloque

est ce lié au mutualisé d'ovh ?
j'ai suivi ce guide
http://www.exolia.fr/guide-lire-49.html
et celui ci
http://forum.eggdrop.fr/InstallerConfigu...-1214.html


dur apres tous ce temps de s'y remettre

cdt Pascal
  Répondre   Avertir
#2
Tout d'abord, l'option --prefix n'est pas obligatoire, elle ne sert qu'à changer le répertoire de destination si celui par défaut ne te convient pas.

Les explications données le sont pour un serveur où les répertoires utilisateurs sont dans /home/, par exemple pour moi: /home/crazycat/ (mon compte est crazycat).
Si j'utilise l'installation par défaut, l'eggdrop sera déployé dans /home/crazycat/eggdrop/
Si je veux que ce soit dans ccbot (dans mon répertoire personnel), j'utiliserai --prefix=/home/crazycat/ccbot

Pour connaitre ton répertoire personnel, une fois connecté via putty, tapes:
Code :
cd ~
pwd
Le système te donnera le chemin complet vers ton "home".
  Répondre   Avertir
#3
ok merci je test ca demain Smile
desolé je suis un peu rouillé Smile

par defaut j'ai fais un tar et je garde le nom du fichier de base

la suite demain
  Répondre   Avertir
#4
bonjour

alors toujours le meme soucis

[Image: http://www.imabox.fr/15/09/151437kPwuS842.png]

pourtant les dossiers sont la mais le MAKE marche pas Sad
j'ai cette version eggdrop1.6.21rc1.tar.gz

ovh doit pas accepter la compilation C
[Image: http://www.imabox.fr/15/09/151439Owp5yA43.png]
  Répondre   Avertir
#5
Ah oui, pas de compilateur installé.
J'imagine que sur un shell mutualisé, tu ne peux utiliser que des choses pré-installées ou seulement des binaires.
  Répondre   Avertir
#6
Regarde éventuellement par ici http://www.egghelp.org/files.htm#precompiled
  Répondre   Avertir
#7
(15/09/2015, 17:52)CrazyCat a écrit : Ah oui, pas de compilateur installé.
J'imagine que sur un shell mutualisé, tu ne peux utiliser que des choses pré-installées ou seulement des binaires.

Oui ovh en mutua en pro

(15/09/2015, 18:10)mcdeffice a écrit : Regarde éventuellement par ici http://www.egghelp.org/files.htm#precompiled

ok merci je vais voir ca demain
  Répondre   Avertir
#8
bonsoir

bon malheureusement j'ai pas trop compris pour la version compilé Sad
je crois que je vais oublier le eggdrop
  Répondre   Avertir
#9
Pour référence et pour ceux que ça intéresse, le problème a été traité lors d'une discussion sur IRC.

Infos sur la distrib de linux utilisée par son shell :
[22:47:52] <HeDeN|Zzz> Linux ssh1.start.ha.ovh.net 3.14.22-grsec-hosting-3.14-grsec-ipv6-64-vps #1 SMP Tue Dec 9 15:43:11 UTC 2014 x86_64 GNU/Linux
[22:48:22] <HeDeN|Zzz> No LSB modules are available.
[22:48:22] <HeDeN|Zzz> Distributor ID: Debian
[22:48:22] <HeDeN|Zzz> Description: Debian GNU/Linux 6.0.7 (squeeze)
[22:48:22] <HeDeN|Zzz> Release: 6.0.7
[22:48:22] <HeDeN|Zzz> Codename: squeeze

Le problème est qu'il semble impossible de trouver un Egg récent précompilé pour cette plateforme.

Solution proposée : installer un Debian en local sous VirtualBox et compiler l'Egg dessus, puis le copier sur le shell.

Solution retenue : installer un Windrop X)
  Répondre   Avertir
#10
Alors les news

avec Slay on a reussi a le lancé , en fait depuis le debut il etait lancé le bot mais impossible de le trouver sur l'irc
apres un -mnt on a vu que le bot avait une erreur dns et stoppé donc la connexion

soucis on a cherché un lonnnnnnnnnnnnnnnnnng moment avec Slay rien a faire
j'ai ouvert les ports de ma box idem
la on seche !

Pascal
  Répondre   Avertir
#11
bonsoir

bon finalement j'ai opté pour un Windrop
j'en profite pour remercier Menzagitat et Slay pour l'aide Smile
  Répondre   Avertir


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  [Résolu] Erreur lors de l'installation à l'étape du "make" sur Raspbian&oq SansFromage 2 618 31/01/2019, 09:48
Dernier message: SansFromage

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)