EggdropFr Announcer (version actuelle : 1.0) (support arrêté)
#1
Description

Le but de ce script est d'annoncer sur votre chan lorsqu'un nouveau message est posté dans la section Scripts TCL du forum www.eggdrop.fr .
Les flux RSS générés par le forum sont actualisés lorsqu'un nouveau thread est créé mais ne permettent pas de savoir lorsqu'une réponse est postée dans un thread existant; par conséquent, ce script ne les utilise pas et parse lui-même le forum pour en dégager l'information utile.

Limitations à connaître :
  • les messages datant de plus de 2 jours ne seront jamais affichés
  • seule la section Scripts TCL est surveillée
  • seule la 1ère page de la section Scripts TCL est surveillée, soient les 50 derniers posts uniquement.
  • la 1ère analyse est déclenchée 3mn après le chargement du script, et ce afin de ne pas surcharger l'eggdrop de tâches dès son lancement.
Le but n'était pas de faire un émulateur RSS complet, inutile donc d'en attendre plus de fonctionnalités que celles que je viens d'énumérer.


Téléchargement

EggdropFr Announcer 1.0
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre
#2
Hello world,

Ha super sympa MenzAgitat pour ce script Smile qui je pense va ravir plus d'un.

merci pour ce travaille,par contre si tu pouvais le mettre en dl sa serais nikel mdr.
Citation :Téléchargement invalide.
La différence entre Linux et Windows ,c'est que Linux c'est comme une belle fille , il faut l'apprivoiser , la comprendre , la séduire tandis que Windows , c'est comme une prostitué , il faut payer et surtout bien se protéger.
  Répondre
#3
Oups, il était bien dans la section téléchargements mais je me suis loupé avec le lien.

C'est corrigé.
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre
#4
Essaye pas.
On le sais que tu voulais le garder pour toi Razz
  Répondre
#5
Bsr MenzAgitat

Super ce script...
j voudrais savoir si c'est possible qu il marche avec d autres site forum ou les nouveaux Threads ou Sujets sont mis ( mais le site /forum n a pas le RSS feed )
  Répondre
#6
Ce script n'est plus d'aucune utilité sur eggdrop.fr étant donné que CrazyCat nous a enfin fait un RSS digne de ce nom.

Pour l'adapter à un autre site, c'est possible moyennant quelques modifications bien entendu. Tout est possible, il suffit juste de le faire :p
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre
#7
bonjour / bonsoir

je viens d'installer le scripts et en pl j'ai cette erreur

[19:00] <eggdrop> [18:52:00] Tcl error in script for 'timer6':
[19:00] <eggdrop> [18:52:00] Unsupported URL: http://tinyurl.com/create.php?url=http:/...st&tid=986
  Répondre
#8
Comme je disais dans le message précédent,
MenzAgitat a écrit :Ce script n'est plus d'aucune utilité sur eggdrop.fr étant donné que CrazyCat nous a enfin fait un RSS digne de ce nom.

Si tu tiens quand même à l'utiliser, tu devras mettre à jour ton package http en version 2.7.5 ou supérieure.
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre
#9
bonjour / bonsoir

il fonctionne encore sur le serveur de crazy mais bon si tu dis qu'il ne sert plus a rien que puis-je mettre a la place le RSS que tu parle c'est lequel stp
  Répondre
#10
http://www.eggdrop.fr/board/last.xml
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre
#11
j'ai mis le http-2.7.5.tcl dans mon eggdrop j'ai rehash le bot et voici mon erreur en pl

[00:20] <eggdrop> [00:12:34] Tcl error in file 'egg.conf':
[00:20] <eggdrop> [00:12:34] conflicting versions provided for package "http": 2.7, then 2.7.5
[00:20] <eggdrop> while executing
[00:20] <eggdrop> "package provide http 2.7.5"
[00:20] <eggdrop> (file "scripts/http-2.7.5.tcl" line 16)
[00:20] <eggdrop> invoked from within
[00:20] <eggdrop> "source scripts/http-2.7.5.tcl"
[00:20] <eggdrop> (file "egg.conf" line 374)
[00:20] <eggdrop> [00:12:34] * FICHIER DE CONFIGURATION NON CHARGE (INTROUVABLE OU ERREUR)
-
DCC session closed
  Répondre
#12
Tu dois d'abord enlever ton ancienne version du package http (la 2.7), tu ne peux pas les cumuler comme ça.
Toute l'actualité de mes scripts ici     (dernière mise à jour le 14/07/2018)

Tout programme comporte au moins un bug et pourrait être raccourci d'au moins une instruction, de quoi l'on peut déduire que tout programme peut être réduit à une seule instruction qui ne fonctionne pas.
  Répondre


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  [Script] Reanimator (version actuelle : 1.2) MenzAgitat 25 9,470 11/05/2019, 00:53
Dernier message: Barback
  [Script] Motus (version actuelle : 3.355) MenzAgitat 450 325,827 10/05/2019, 13:19
Dernier message: Barback
  [Script] Duck Hunt (version actuelle : 2.11) MenzAgitat 33 10,343 24/02/2019, 18:52
Dernier message: LokYnesS
  [Script] DicoReverso (version actuelle : 1.02) MenzAgitat 2 3,644 16/07/2018, 11:43
Dernier message: MenzAgitat
  [Script] Automatic Translator (version actuelle : 1.03) MenzAgitat 6 3,797 26/12/2017, 20:50
Dernier message: templala
  [Script] Oracle (version actuelle : 2.3.1) MenzAgitat 16 9,099 14/09/2017, 16:21
Dernier message: MenzAgitat
  [Script] MediaDico (version actuelle : 3.125) MenzAgitat 29 18,511 19/07/2017, 01:41
Dernier message: MenzAgitat
  [Script] Interface MegaHAL (version actuelle : 4.1.0) MenzAgitat 109 57,798 13/05/2017, 18:50
Dernier message: Vanadiium
  Public Quotes System (version actuelle : 2.52) MenzAgitat 100 56,372 07/03/2017, 19:26
Dernier message: Rikudo
  [Script] Menz Agitat's Timebomb (version actuelle : 1.3) MenzAgitat 9 6,008 20/08/2016, 21:13
Dernier message: R0uLi

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)