Chanrelay Avec SSl
#1
Bonjour,

Je viens de mettre à jours mon eggdrop en 1.8 avec la gestion du ssl.
Actuellement j'ai besoin de faire un relay donc j'ai repris le super script chan relay.

je refais la configuration et malheureusement au niveau links sa bloc j'ai l'erreur suivante : failed link to BOT2

pouvez-vous me donner une commande ou me dire ou trouver le code d'erreur précis pour corriger ?
car actuellement je sèche un peu.

merci d'avance cordialement,
  Répondre   Avertir
#2
Cette erreur n'est pas due à chanrelay (qui ne gère pas le link botnet), je pense que ton souci est juste dans le linkage de tes eggdrops.
Il n'y a d'ailleurs pas de bloc "link" dans chanrelay, ou bien tu ne parles pas de http://scripts.eggdrop.fr/details-ChanRelay-s1.html ?
  Répondre   Avertir
#3
Bonjour,

Je parle bien du script que tu as créer.
en effet quand je lance la commande :

Sur le hub :
.+bot bot2 127.0.0.1:portbot/portall
.chattr bot2 +f

Sur le bot2 :
.+bot bot1 127.0.0.1:portbot/portall
.botattr bot1 +h

Au moment de se linked il me dit qu'il y a une erreur.

Ce que je trouve Bizard mais bon ^^
au besoin je peux changer les ports et voir ce que sa donne mais cela fonctionné avant sans ssl j'ai juste ajouter le ssl.
je ne pense pas que le ssl bloque quelques choses.

en tout cas merci pour ta réponse et si tu as une commande pour voir plus en détails je suis preneur.


bon dimanche
  Répondre   Avertir
#4
Essaye:
Code :
<bot1> .console +bd
Code :
<bot2> .console +bd
<bot2> .link bot1
Tu auras peut être plus d'infos dans les party-lines des 2 bots
  Répondre   Avertir
#5
Merci pour les commandes.
Par contre toujours rien, je voie l'appel je voie le test de connexion et boum erreur.

c'est pas grave je vais refaire une configuration complète demain et je reviens poster, je pense cela va solutionner le problème.

Par contre une question sur le chanrelay c'est possible de ce faire bannir si un réseau n'autorise pas le eggdrop ?
si oui comment le voie-ton que c'est un bot et non un humain ?

Merci pour ton aide comme toujours

Bonne fin d'après-midi
  Répondre   Avertir
#6
Je n'ai pas fait attention à ta commande et au fait que tu étais en eggdrop 1.8:
Code :
.+bot bot2 127.0.0.1:portbot/portall
Sauf que si on cherche un peu, on lit:
eggwiki a écrit :Because of IPv6 addresses having ":" as valid character, the syntax for some commands where you specify addresses (.chaddr, .+bot) might have been changed, check .help <cmd> before using them.

Et en faisant un .help +bot:
help a écrit :### +bot <handle> [address [[+]bot port[/[+]user port]]] [host]
Creates a user record for a new bot with the handle given. If no hostmask
is specified, the bot will try to automatically add a host from the channel.
The bot's address will be used in linking. If the bot has a separate port
for bots and users they should be separated with a slash (/). Prefixing
the port with a plus sign marks the bot for secure (SSL) linking.

Je pense que tu as toutes les infos maintenant.


Encore une fois, tes questions ne sont pas en rapport avec chanrelay mais avec l'eggdrop et sa connexion.

Oui, un réseau peut interdire les eggdrops, en se basant sur le ctcp version ou sur le flag +B, ou juste sur la suspicion d'un ircop. Mais avec ou sans chanrelay, si ton eggdrop est banni, il est banni.
  Répondre   Avertir
#7
Bonjour,

Suite à ton test de la dernier version de eggdrop j'ai trouvé le problème.

pour linker les bot il ne faut plus utiliser le ":" et cela fonctionne.

encore merci pour tes réponses.
  Répondre   Avertir


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)