Mise en forme de code: pensez à utiliser les balises [ tcl ] et [ /tcl ] (sans les espaces bien sûr) autour de vos codes tcl afin d'avoir un meilleur rendu et une coloration syntaxique. x


[Résolu] Aucune commande ne fonctionne
#1
Sad 
Bonsoir à tous
Alors j'ai un souci avec un bot anim que j'ai créé moi même
Quand je tape !cmd je n'ai rien qui s'affiche sur le salon et j'ai aucun message d'erreur en PL je capte pas
Voila le code

Code:
bind pubm - * pub:animation
proc pub:animation { nick uhost handle channel arg } {
 set arg [stripcodes bcruag $arg]
 set commande [lindex $arg 0]
 switch -- $commande {
   "!cmd" {
putquick "NOTICE $nick :\0032Pour faire fonctionner les commandes il faut taper de la maniere suivante !cmd pseudo ( exemple: !bierre Thor )"
putquick "NOTICE $nick :\0031Les commandes\00312 !oracle !story !chuck\0031 sont a taper en noir !"
putquick "NOTICE $nick :\0036Voici les commandes de Thor"
putquick "NOTICE $nick :\0037Les commandes barman:"
putquick "NOTICE $nick :\00312!biere\0034 !coca\00312 !sky\0034 !cafe\00312 !champagne"
putquick "NOTICE $nick :\0037Les commandes love:"
putquick "NOTICE $nick :\00312!kiss\0034 !palo\00312 !love\0034 !calin\00312 !rose\0034 !sexy\00312 !plotte"
putquick "NOTICE $nick :\0037Les commandes violantes:"
putquick "NOTICE $nick :\00312!fouette\0034 !baffe\00312 !relou\0034 !vanne\00312 !cb\0034 !pelle"
putquick "NOTICE $nick :\0037Les commandes diverses:"
putquick "NOTICE $nick :\00312!clope \0034!story"
putquick "NOTICE $nick :\0036Fin des commandes de Thor"
}
}
}

proc pub:animation { nick uhost handle chan arg } {
set commande [lindex $arg 1]
set commande [stripcodes bcruag [lindex $arg 0]]
switch -- $commande {
"!biere" {
if {[lrange $arg 1 end] == ""} {
putquick "PRIVMSG $chan :\0037$nick \00312se décapsule une bonne bière bien fraiche."
} else {
putquick "PRIVMSG $chan :\0037$nick \00312offre une bonne bière bien fraiche à\0034 [lrange $arg 1 end] \00312."
  }
 }
}
}
Franchement je comprend pas
Merci d'avance

EDIT : oublier de préciser que mon eggdrop est un 1.6.21 j'ai aussi tenté de remplacer $chan par $channel mais non rien ne change tjrs rien ne s'affiche sur salon et aucun message en PL...
#2
Le fait d'avoir deux fois la même procédure ne te choque pas ?
Et dans la première, quel est l'intérêt du switch pour un seul cas ?
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
#3
ho le blond et pourtant j'ai relu et relu et encore relu le code...
effectivement en changeant la procédure sa marche pour les commandes.
En se qui concerne la première procédure je pourrais très bien faire quelque chose comme ça

Code:
bind pub - "!cmd" pub:cmd
bind pub - "!cmds" pub:cmd
bind pub - "!liste" pub:cmd
bind pub - "!jokes" pub:cmd
bind pub - "!commande" pub:cmd

proc pub:cmd { nick uhost handle chan arg } {
   putquick "NOTICE $nick :\0032Pour faire fonctionner les commandes il faut taper de la manière suivante !cmd pseudo ( exemple: !bierre AngeDesOmbres )"
   putquick "NOTICE $nick :\0036Voici les commandes de Thor"
}
mais je ne risque pas d'avoir des soucies avec les personnes qui écrivent en couleur ?

EDIT : résolu toute les commendes fonctionne bien
merci de m'voir ouvert les yeux et désolé de vous avoir déranger pour une erreur comme ça...
bye
#4
Ce que je ne comprends pas, c'est pourquoi tu ne mets pas tes "!cmd", "!cmds" et autres dans le même switch que le reste, et que ces valeurs ne lancent pas la procédure d'affichage de l'aide.

Et tu sais qu'il y a déjà un script de ce genre: http://scripts.eggdrop.fr/details-Jokes-s71.html
irc.zeolia.net - Offrez-moi un café
Merci de ne pas demander d'aide en MP
Away
#5
oui crazycat je connais se tcl je l'ai utiliser un bon moment :)
je compte d'ailleur m'en inspirer pour la prochaine version de mon bot
merci de ton aide en tous cas


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Résolu] Youtube tcl (Zurl.tcl) ne fonctionne plus Krypte 23 14,412 28/04/2017, 18:22
Last Post: Alucard`68
  TCL Auto-sajoin fonctionne partiellement. Aristide 24 15,401 24/02/2017, 17:36
Last Post: cestlemien
  msg.tcl , il fonctionne mais dans un seul chan kanotix 5 5,545 06/06/2008, 14:20
Last Post: N3bIlIm

Forum Jump:


Users browsing this thread: 1 Guest(s)